aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm427
1 files changed, 346 insertions, 81 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5c2e623705..c91b0ee75e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016, 2017 Ben Woodcroft <donttrustben@gmail.com>
-;;; Copyright © 2016, 2017, 2018 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2016, 2017, 2018, 2020 Roel Janssen <roel@gnu.org>
;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Raoul Bonnal <ilpuccio.febo@gmail.com>
;;; Copyright © 2018 Vijayalakshmi Vedantham <vijimay12@gmail.com>
@@ -83,6 +83,25 @@
#:use-module (gnu packages web)
#:use-module (gnu packages xorg))
+(define-public r-bezier
+ (package
+ (name "r-bezier")
+ (version "1.1.2")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "bezier" version))
+ (sha256
+ (base32
+ "1vw5128v8h973xwa1fdm9cw2jvrldj87nd55lddlp3qsz3ag4br6"))))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/bezier/")
+ (synopsis "Bezier curve and spline toolkit")
+ (description
+ "This package is a toolkit for working with Bezier curves and splines.
+The package provides functions for point generation, arc length estimation,
+degree elevation and curve fitting.")
+ (license license:gpl2+)))
+
(define-public r-clipr
(package
(name "r-clipr")
@@ -102,6 +121,36 @@
the system clipboards.")
(license license:gpl3)))
+(define-public r-ggpmisc
+ (package
+ (name "r-ggpmisc")
+ (version "0.3.4")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "ggpmisc" version))
+ (sha256
+ (base32
+ "0xc1yp0kphipq23ri4ij93garx1x2nrf4i0lhs6m10pp9yz7fbmj"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-broom" ,r-broom)
+ ("r-dplyr" ,r-dplyr)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-gridextra" ,r-gridextra)
+ ("r-lubridate" ,r-lubridate)
+ ("r-mass" ,r-mass)
+ ("r-plyr" ,r-plyr)
+ ("r-polynom" ,r-polynom)
+ ("r-splus2r" ,r-splus2r)
+ ("r-tibble" ,r-tibble)
+ ("r-xts" ,r-xts)
+ ("r-zoo" ,r-zoo)))
+ (home-page "https://www.r4photobiology.info/")
+ (synopsis "Miscellaneous Extensions to @code{ggplot2}")
+ (description "This package provides extensions to @code{ggplot2},
+respecting the grammar of its graphics paradigm.")
+ (license license:gpl2+)))
+
(define-public r-oenb
(package
(name "r-oenb")
@@ -177,6 +226,30 @@ legends.")
control over dimensions and appearance.")
(license license:gpl2+)))
+(define-public r-ecp
+ (package
+ (name "r-ecp")
+ (version "3.1.2")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "ecp" version))
+ (sha256
+ (base32
+ "11f9p869xr0zg779i46gmflxlq4xclk9wxbab0nj2fan26pn4sfy"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-rcpp" ,r-rcpp)))
+ (home-page "https://cran.r-project.org/web/packages/ecp/")
+ (synopsis "Multiple change-point analysis of multivariate data")
+ (description
+ "This package implements various procedures for finding multiple
+change-points. Two methods make use of dynamic programming and pruning, with
+no distributional assumptions other than the existence of certain absolute
+moments in one method. Hierarchical and exact search methods are included.
+All methods return the set of estimated change-points as well as other summary
+information.")
+ (license license:gpl2+)))
+
(define-public r-ellipsis
(package
(name "r-ellipsis")
@@ -449,6 +522,27 @@ small, reproducible, and runnable examples on code-oriented websites or email.
such as copy/paste from an R session.")
(license license:expat)))
+(define-public r-reordercluster
+ (package
+ (name "r-reordercluster")
+ (version "1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "ReorderCluster" version))
+ (sha256
+ (base32
+ "0ss750frzvj0bm1w7zblmcsjpszhnbffwlkaw31sm003lbx9hy58"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-gplots" ,r-gplots)
+ ("r-rcpp" ,r-rcpp)))
+ (home-page "https://cran.r-project.org/web/packages/ReorderCluster")
+ (synopsis "Reordering the dendrogram according to the class labels")
+ (description "This package provides tools for performing the leaf reordering
+for the dendrogram that preserves the hierarchical clustering result and at the
+same time tries to group instances from the same class together.")
+ (license license:gpl3+)))
+
(define-public r-callr
(package
(name "r-callr")
@@ -1027,13 +1121,13 @@ application framework for R, making it easy to create attractive dashboards.")
(define-public r-shinyfiles
(package
(name "r-shinyfiles")
- (version "0.7.5")
+ (version "0.8.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "shinyFiles" version))
(sha256
- (base32 "1143m941hma9hc77c3xcw26c0ygfhn9ii2sbp9wrydxv4gc7mr8a"))))
+ (base32 "0gwyx37f2r86cldsyknws9pafpj8g5mg3mchlyl9ymgnk5f4b88w"))))
(properties `((upstream-name . "shinyFiles")))
(build-system r-build-system)
(propagated-inputs
@@ -1677,13 +1771,13 @@ processes. Most of its code is based on the @code{psutil} Python package.")
(define-public r-pkgbuild
(package
(name "r-pkgbuild")
- (version "1.0.6")
+ (version "1.0.7")
(source
(origin
(method url-fetch)
(uri (cran-uri "pkgbuild" version))
(sha256
- (base32 "0xnlz6ivhkbmncg9hfw5p69lm4rjy3wn5lyxmygxyf4rrfnnqwxx"))))
+ (base32 "0wd9678yp6yi73n92f58wi9jc19gdq5cmbj65l6pifh2haikifr9"))))
(build-system r-build-system)
(propagated-inputs
`(("r-callr" ,r-callr)
@@ -1910,17 +2004,19 @@ multi-dimensional data.")
(define-public r-powerlaw
(package
(name "r-powerlaw")
- (version "0.70.4")
+ (version "0.70.6")
(source
(origin
(method url-fetch)
(uri (cran-uri "poweRlaw" version))
(sha256
- (base32 "19zah9mx93az5lh9vicn3c8q1xb12g0w46dh5p901fbyimc32vwk"))))
+ (base32 "14d1myxllvm1grnfiszzzxaiqpb2jpmsi19wq70r8r2wki293h7g"))))
(properties `((upstream-name . "poweRlaw")))
(build-system r-build-system)
(propagated-inputs
- `(("r-vgam" ,r-vgam)))
+ `(("r-pracma" ,r-pracma)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
(home-page "https://github.com/csgillespie/poweRlaw")
(synopsis "Tools for the analysis of heavy tailed distributions")
(description
@@ -2029,14 +2125,14 @@ any subsequent lookup as it keeps the hash table in memory.")
(define-public r-ff
(package
(name "r-ff")
- (version "2.2-14")
+ (version "2.2-14.2")
(source
(origin
(method url-fetch)
(uri (cran-uri "ff" version))
(sha256
(base32
- "1w724q4jpzbvzpilb2ifviaxkjgk9lzwxz9gksnvicbmfa20fqqw"))))
+ "1r1pbrf5s4rdm3msxxr8fy1f2xjihqciclsnvxf59qzz6g1nmh7q"))))
(build-system r-build-system)
(propagated-inputs `(("r-bit" ,r-bit)))
(home-page "http://ff.r-forge.r-project.org/")
@@ -2176,14 +2272,14 @@ plot networks.")
(define-public r-proxy
(package
(name "r-proxy")
- (version "0.4-23")
+ (version "0.4-24")
(source
(origin
(method url-fetch)
(uri (cran-uri "proxy" version))
(sha256
(base32
- "17b6qfllqrhzrxqgx7dccffgybnkcria5a68ap5ly3plg04ypm4x"))))
+ "0z4wdnpv5x135nssxnmkkba7fivd5xgbpaabqjkl2na76vq9pzwc"))))
(build-system r-build-system)
(home-page "https://cran.r-project.org/web/packages/proxy")
(synopsis "Distance and similarity measures")
@@ -2293,14 +2389,14 @@ quantile mixture from L-moments and trimmed L-moments.")
(define-public r-distillery
(package
(name "r-distillery")
- (version "1.0-6")
+ (version "1.0-7")
(source
(origin
(method url-fetch)
(uri (cran-uri "distillery" version))
(sha256
(base32
- "1mi3ig9jq0kd7yrwc5m37lmrw04p1b4lirnbsxi10z3n5yay4429"))))
+ "0w72vb3p51m0hwms9icwgy1xg3dplmpjrxibl2s92lpdrv737249"))))
(build-system r-build-system)
(home-page "https://ral.ucar.edu/staff/ericg/")
(synopsis "Functions for confidence intervals and object information")
@@ -2400,6 +2496,27 @@ and S4 methods with inlined C, C++ or Fortran code supporting @code{.C} and
;; Any version of the LGPL.
(license license:lgpl3+)))
+(define-public r-inum
+ (package
+ (name "r-inum")
+ (version "1.0-1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "inum" version))
+ (sha256
+ (base32
+ "16d09391l65w557dkzhhx1aqn1ljamcmjj3yh42pwq037k0r8brw"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-libcoin" ,r-libcoin)))
+ (home-page "https://cran.r-project.org/web/packages/inum/")
+ (synopsis "Interval and enum-type representation of vectors")
+ (description
+ "This package provides an enum-type representation of vectors and
+representation of intervals, including a method of coercing variables
+in data frames.")
+ (license license:gpl2)))
+
(define-public r-bdsmatrix
(package
(name "r-bdsmatrix")
@@ -3105,14 +3222,14 @@ by base R methods related to model fitting.")
(define-public r-broom
(package
(name "r-broom")
- (version "0.5.5")
+ (version "0.5.6")
(source
(origin
(method url-fetch)
(uri (cran-uri "broom" version))
(sha256
(base32
- "0n7zd64263kfavdi28rl2bxrsa00c3m4vjhhjdrfwvvmrcxj39fx"))))
+ "0da3jsb02xckrk6alznicn6l5lnyvdhc64qklyarnd77miqgc1hb"))))
(build-system r-build-system)
(propagated-inputs
`(("r-backports" ,r-backports)
@@ -3124,6 +3241,8 @@ by base R methods related to model fitting.")
("r-stringr" ,r-stringr)
("r-tibble" ,r-tibble)
("r-tidyr" ,r-tidyr)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
(home-page "https://github.com/tidyverse/broom")
(synopsis "Convert statistical analysis objects into tidy data frames")
(description
@@ -3926,14 +4045,14 @@ timeout. It can also poll several processes at once.")
(define-public r-tsp
(package
(name "r-tsp")
- (version "1.1-9")
+ (version "1.1-10")
(source
(origin
(method url-fetch)
(uri (cran-uri "TSP" version))
(sha256
(base32
- "183m6crb0dv17llj86059n3hbgsahbhfcqlx0ijdzkssg11i1cy7"))))
+ "0z1v6m0vqjzxc4az3zyjaayygx0jr3mdmc56jjd421iqh0b9z5s4"))))
(properties `((upstream-name . "TSP")))
(build-system r-build-system)
(propagated-inputs `(("r-foreach" ,r-foreach)))
@@ -4195,14 +4314,14 @@ terminals.")
(define-public r-tinytex
(package
(name "r-tinytex")
- (version "0.21")
+ (version "0.22")
(source
(origin
(method url-fetch)
(uri (cran-uri "tinytex" version))
(sha256
(base32
- "088zzc2v0izbcs45p19v547pi78vkr08ibpvvi1g9bkbya4x3mq9"))))
+ "0s9f62v3ps5f8903ar6kxlf1z3b4v78vlw1nb05bq55dgj8brg3b"))))
(build-system r-build-system)
(propagated-inputs
`(("r-xfun" ,r-xfun)))
@@ -6456,14 +6575,14 @@ other add-on packages.")
(define-public r-insight
(package
(name "r-insight")
- (version "0.8.2")
+ (version "0.8.3")
(source
(origin
(method url-fetch)
(uri (cran-uri "insight" version))
(sha256
(base32
- "0fjf7dwpv1a7qfbzixppg348z1ksq19kdjm08vcb2am7w0k3plcj"))))
+ "0lm5a4r368mq1pwmxjk2xnz25lb9j4v7mdkl1bahk2alklxgb8yj"))))
(build-system r-build-system)
(native-inputs
`(("r-knitr" ,r-knitr)))
@@ -6965,14 +7084,14 @@ bootstrap. Confidence intervals can be computed for (p)AUC or ROC curves.")
(define-public r-rootsolve
(package
(name "r-rootsolve")
- (version "1.8.2")
+ (version "1.8.2.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "rootSolve" version))
(sha256
(base32
- "0rj7c4zcrzgz7sb0vgvh7swpfafnw4040cxp7ypas3s8fnihn54l"))))
+ "0c9hhgq1pgqdg80a6n2ssfbj5nyaf97y4iiya7j7l6b34qc53128"))))
(properties `((upstream-name . "rootSolve")))
(build-system r-build-system)
(native-inputs `(("gfortran" ,gfortran)))
@@ -7313,14 +7432,14 @@ used to teach mathematics, statistics, computation and modeling.")
(define-public r-raster
(package
(name "r-raster")
- (version "3.0-12")
+ (version "3.1-5")
(source
(origin
(method url-fetch)
(uri (cran-uri "raster" version))
(sha256
(base32
- "0rrbsigkqxsdic8fly6nrsc79zsliwvr1x2b4xqpl9d34vr50dvg"))))
+ "010sq00ijpmwac280ip9rryw0pxk0al8g675v2lc9rdrbgaj4rnv"))))
(build-system r-build-system)
(propagated-inputs
`(("r-rcpp" ,r-rcpp)
@@ -8324,14 +8443,14 @@ Hothorn, Westfall, 2010, CRC Press).")
(define-public r-emmeans
(package
(name "r-emmeans")
- (version "1.4.5")
+ (version "1.4.6")
(source
(origin
(method url-fetch)
(uri (cran-uri "emmeans" version))
(sha256
(base32
- "10fmvmd6q4zjr6b18hhc85mwrzv778qzj6lwl9kbs2fsfvsgw7mm"))))
+ "0mxk7ghlv4r6sna4897q1la2xgyn1dw3r9srhm9x4h5l4701avfa"))))
(build-system r-build-system)
(propagated-inputs
`(("r-estimability" ,r-estimability)
@@ -8339,6 +8458,8 @@ Hothorn, Westfall, 2010, CRC Press).")
("r-numderiv" ,r-numderiv)
("r-plyr" ,r-plyr)
("r-xtable" ,r-xtable)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
(home-page "https://github.com/rvlenth/emmeans")
(synopsis "Estimated marginal means, aka least-squares means")
(description
@@ -8557,14 +8678,14 @@ differentiation.")
(define-public r-bayestestr
(package
(name "r-bayestestr")
- (version "0.5.3")
+ (version "0.6.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "bayestestR" version))
(sha256
(base32
- "1q24qh5p6bz4nbf4546kckh7d518x5pm1yhhbc8fwcnbca4kgqjz"))))
+ "0s7wdmk8avgaqk2b7fcf4bsh13isrkl1q4y7z2y8jhdagxxxnzd1"))))
(properties `((upstream-name . "bayestestR")))
(build-system r-build-system)
(propagated-inputs
@@ -8611,14 +8732,14 @@ effects models and Bayesian models.")
(define-public r-ggeffects
(package
(name "r-ggeffects")
- (version "0.14.2")
+ (version "0.14.3")
(source
(origin
(method url-fetch)
(uri (cran-uri "ggeffects" version))
(sha256
(base32
- "1y3yfb07jrr6vkc8hk6rp52l70dj7042jvqgjzllslzy7hx2jhyw"))))
+ "06p80bgjhjknzlb4vs4n41i9n9vv5agncakl9f92zkaahgyzd6sd"))))
(build-system r-build-system)
(propagated-inputs
`(("r-insight" ,r-insight)
@@ -8799,14 +8920,14 @@ terminals that do not support Unicode.")
(define-public r-usethis
(package
(name "r-usethis")
- (version "1.6.0")
+ (version "1.6.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "usethis" version))
(sha256
(base32
- "12iyimqyza752anj29wpfisl8nz5r25kfcqbssybg24nb4wyy146"))))
+ "0vwxsnq615mwc706a4a71gyy0hmvnllbh249gzm7vl3ym5cr0cv0"))))
(build-system r-build-system)
(propagated-inputs
`(("r-cli" ,r-cli)
@@ -9395,14 +9516,14 @@ Bioconductor packages.")
(define-public r-rgl
(package
(name "r-rgl")
- (version "0.100.50")
+ (version "0.100.54")
(source
(origin
(method url-fetch)
(uri (cran-uri "rgl" version))
(sha256
(base32
- "165p932ml7dpjkm41zc47p5cdxar69il0m5yvg0avi8q01vr17ay"))))
+ "1mgs2d8igmcdzzymfwbqdrypmaidd4pra5n5gnhsn9pm6pqzidqp"))))
(build-system r-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -9534,14 +9655,14 @@ features (e.g. local modes).")
(define-public r-arm
(package
(name "r-arm")
- (version "1.10-1")
+ (version "1.11-1")
(source
(origin
(method url-fetch)
(uri (cran-uri "arm" version))
(sha256
(base32
- "0vvp90jygajd6ydky57z66wqjq9msfbl88irj5jbsray574mh4bg"))))
+ "0i2lnm09bqy1qw0ms5pw0rzw196xmnk5dxha3g8lc58lqpldp0kv"))))
(build-system r-build-system)
(propagated-inputs
`(("r-abind" ,r-abind)
@@ -11478,14 +11599,14 @@ library.")
(define-public r-protviz
(package
(name "r-protviz")
- (version "0.6.3")
+ (version "0.6.4")
(source
(origin
(method url-fetch)
(uri (cran-uri "protViz" version))
(sha256
(base32
- "1ldciqh3f43xr9663yyhd9r6qwrg4c4vmkprlcancbnd460wakg7"))))
+ "1qq9bf4485x8cviry9fmhnv4hw9aw657w134003myzcv42c4pml6"))))
(properties `((upstream-name . "protViz")))
(build-system r-build-system)
(propagated-inputs `(("r-rcpp" ,r-rcpp)))
@@ -11528,14 +11649,14 @@ JASA, 94:496-509.")
(define-public r-etm
(package
(name "r-etm")
- (version "1.0.5.1")
+ (version "1.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "etm" version))
(sha256
(base32
- "0m41pm277sd50pharigcqzr1a2g92wnmdf6fcab6fx16ia2fzrm7"))))
+ "02yvh473l5qajaymhsxwb235a9r7q3nsig9a9mrfca68xih8yvgd"))))
(build-system r-build-system)
(propagated-inputs
`(("r-data-table" ,r-data-table)
@@ -11736,14 +11857,14 @@ them in distributed compute environments.")
(define-public r-future
(package
(name "r-future")
- (version "1.16.0")
+ (version "1.17.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "future" version))
(sha256
(base32
- "1xaqh0b2knf5bp23mc0kriq0iqhqna31q3b7d960piqjhzrb03dm"))))
+ "0d4y7gwcgqx2z0y6h5bh4lrz0m7b0inii5cjcq0kk8za762bi8rg"))))
(build-system r-build-system)
(propagated-inputs
`(("r-digest" ,r-digest)
@@ -11768,14 +11889,14 @@ the local machine to, say, distributed processing on a remote compute cluster.")
(define-public r-future-apply
(package
(name "r-future-apply")
- (version "1.4.0")
+ (version "1.5.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "future.apply" version))
(sha256
(base32
- "1kgq6dv96hdy35kysqkn606nj7s9dp4ibgpm6n46gqhc5n75lzkk"))))
+ "095a681ngbwbp7v53ladwya7ar8fgwnlgr3r1yklf3vdxwd54xll"))))
(properties `((upstream-name . "future.apply")))
(build-system r-build-system)
(propagated-inputs
@@ -13234,14 +13355,14 @@ tessellation.")
(define-public r-sf
(package
(name "r-sf")
- (version "0.9-1")
+ (version "0.9-2")
(source
(origin
(method url-fetch)
(uri (cran-uri "sf" version))
(sha256
(base32
- "1qghrskqwwlwxmmvkv7knhlr1a32ngyimycasy5gfazgviljsfn4"))))
+ "01xplgy5nlwy3ajfch4h1ssa1xhm7q0jzscpz04dmvgqfzwhhdfh"))))
(build-system r-build-system)
(inputs
`(("gdal" ,gdal)
@@ -13730,17 +13851,19 @@ authoring books and technical documents with R Markdown.")
(define-public r-optparse
(package
(name "r-optparse")
- (version "1.6.4")
+ (version "1.6.6")
(source
(origin
(method url-fetch)
(uri (cran-uri "optparse" version))
(sha256
(base32
- "0wyrc42ja3ab5szx46zmz8lm7vzfqxkjca0m0sms8g9hqbmmay6d"))))
+ "1l301dy3gc8pn7j00awcjh41wmc1ks9kswak255kbsa6f54rsxsi"))))
(build-system r-build-system)
(propagated-inputs
`(("r-getopt" ,r-getopt)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
(home-page "https://github.com/trevorld/optparse")
(synopsis "Command line option parser")
(description
@@ -14900,18 +15023,19 @@ external dependencies. This package has is implemented purely in R.")
(define-public r-rex
(package
(name "r-rex")
- (version "1.1.2")
+ (version "1.2.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "rex" version))
(sha256
(base32
- "0alsadgjgass3wr8y5d247j12qqzg454sc84vpskclrkmz778g5x"))))
+ "0m7bq8db3m5dhf01rw7xc7xy1ciq3m7dfgsl80p8cy4h8vqr3d06"))))
(build-system r-build-system)
(propagated-inputs
- `(("r-lazyeval" ,r-lazyeval)
- ("r-magrittr" ,r-magrittr)))
+ `(("r-lazyeval" ,r-lazyeval)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
(home-page "https://github.com/kevinushey/rex")
(synopsis "Friendly regular expressions")
(description
@@ -15242,20 +15366,89 @@ engine (Salmon et al., 2011) as provided by the package @code{sitmo}.")
;; whole is distributed under the terms of the AGPL 3.
(license license:agpl3)))
+(define-public r-ingredients
+ (package
+ (name "r-ingredients")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ingredients" version))
+ (sha256
+ (base32
+ "1q196y9xzn4wk44fa1bvh0hcbizgm93rwir82nyk31k5pgixk967"))))
+ (properties `((upstream-name . "ingredients")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-gridextra" ,r-gridextra)
+ ("r-scales" ,r-scales)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://ModelOriented.github.io/ingredients/")
+ (synopsis "Effects and importances of model ingredients")
+ (description
+ "This is a collection of tools for assessment of feature importance and
+feature effects. Key functions are:
+
+@itemize
+@item @code{feature_importance()} for assessment of global level feature
+ importance,
+@item @code{ceteris_paribus()} for calculation of the what-if plots,
+@item @code{partial_dependence()} for partial dependence plots,
+@item @code{conditional_dependence()} for conditional dependence plots,
+@item @code{accumulated_dependence()} for accumulated local effects plots,
+@item @code{aggregate_profiles()} and @code{cluster_profiles()} for
+ aggregation of ceteris paribus profiles,
+@item generic @code{print()} and @code{plot()} for better usability of
+ selected explainers,
+@item generic @code{plotD3()} for interactive, D3 based explanations, and
+@item generic @code{describe()} for explanations in natural language.
+@end itemize\n")
+ (license license:gpl3)))
+
+(define-public r-ibreakdown
+ (package
+ (name "r-ibreakdown")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "iBreakDown" version))
+ (sha256
+ (base32
+ "0y4zjpyn8j76jrs5phjzs5lfq3lqjspmrwcksqv9wq0rbdgh14vk"))))
+ (properties `((upstream-name . "iBreakDown")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-ggplot2" ,r-ggplot2)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://ModelOriented.github.io/iBreakDown/")
+ (synopsis "Model agnostic instance level variable attributions")
+ (description
+ "This package provides a model agnostic tool for decomposition of
+predictions from black boxes. It supports additive attributions and
+attributions with interactions. The Break Down Table shows contributions of
+every variable to a final prediction. The Break Down Plot presents variable
+contributions in a concise graphical way. This package works for
+classification and regression models.")
+ (license license:gpl3)))
+
(define-public r-dalex
(package
(name "r-dalex")
- (version "1.0.1")
+ (version "1.2.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "DALEX" version))
(sha256
(base32
- "1jbyn57vn6d281a5y15h5d8ljin8cdb9lr7lbgggc950blyfv4g0"))))
+ "0lx8nasm1zgh1ckz8nw3ysp6xjv3dsj39hzhr6k3xhh6i8pm9rxk"))))
(properties `((upstream-name . "DALEX")))
(build-system r-build-system)
- (propagated-inputs `(("r-ggplot2" ,r-ggplot2)))
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-ibreakdown" ,r-ibreakdown)
+ ("r-ingredients" ,r-ingredients)))
(home-page "https://pbiecek.github.io/DALEX/")
(synopsis "Descriptive machine learning explanations")
(description
@@ -15317,14 +15510,14 @@ includes data sets from oceanography.")
(define-public r-ggfortify
(package
(name "r-ggfortify")
- (version "0.4.9")
+ (version "0.4.10")
(source
(origin
(method url-fetch)
(uri (cran-uri "ggfortify" version))
(sha256
(base32
- "1p6knrbyaynaqwd939w09hpf1zz1gn95cb46sfgppl8l98krb2h5"))))
+ "0wmcwp63h90v3f00ixszvis4z28im621jickvc0wgi6qvjvnayq0"))))
(build-system r-build-system)
(propagated-inputs
`(("r-dplyr" ,r-dplyr)
@@ -15833,22 +16026,22 @@ both R code and compiled C/C++/FORTRAN code.")
(define-public r-systemfonts
(package
(name "r-systemfonts")
- (version "0.1.1")
+ (version "0.2.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "systemfonts" version))
(sha256
(base32
- "0m0ljid683xcam2f14x7k2zv1yx4npac38a3gfv11vhxfbnpgp0z"))))
+ "0dna00xai0pw76b4830yy4r5j1hq7f7kla67v0iz39cjm4rq4ygq"))))
(properties `((upstream-name . "systemfonts")))
(build-system r-build-system)
(inputs
`(("fontconfig" ,fontconfig)
- ("freetype" ,freetype)
("zlib" ,zlib)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)
+ ("r-knitr" ,r-knitr)))
(home-page "https://github.com/r-lib/systemfonts")
(synopsis "System native font finding")
(description
@@ -15862,14 +16055,14 @@ be used further by e.g. graphic devices.")
(define-public r-graphlayouts
(package
(name "r-graphlayouts")
- (version "0.6.0")
+ (version "0.7.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "graphlayouts" version))
(sha256
(base32
- "1la016m37kp79zk8p1yx9kaha8y6d4w52w39h0mzv1mfsi6d75w0"))))
+ "17lc75k8i3c696hfj44zj7j1a5sb0nap8spc5r98v7vd6xh4nii0"))))
(properties `((upstream-name . "graphlayouts")))
(build-system r-build-system)
(propagated-inputs
@@ -16756,28 +16949,61 @@ for original research. A variety of user defined options and formatting are
included.")
(license license:gpl3)))
+(define-public r-qgam
+ (package
+ (name "r-qgam")
+ (version "1.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "qgam" version))
+ (sha256
+ (base32
+ "0lks2cj0p7irp1i01756v1l7i26d7alax1fbkc20qd6wpz840fi7"))))
+ (properties `((upstream-name . "qgam")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-doparallel" ,r-doparallel)
+ ("r-mgcv" ,r-mgcv)
+ ("r-plyr" ,r-plyr)
+ ("r-shiny" ,r-shiny)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://cran.r-project.org/web/packages/qgam/")
+ (synopsis "Smooth additive quantile regression models")
+ (description
+ "This package provides smooth additive quantile regression models, fitted
+using the methods of Fasiolo et al. (2017). Differently from @code{quantreg},
+the smoothing parameters are estimated automatically by marginal loss
+minimization, while the regression coefficients are estimated using either
+PIRLS or Newton algorithm. The learning rate is determined so that the
+Bayesian credible intervals of the estimated effects have approximately the
+correct coverage. The main function is @code{qgam()} which is similar to
+@code{gam()} in the @code{mgcv} package, but fits non-parametric quantile
+regression models.")
+ (license license:gpl2+)))
+
(define-public r-abtest
(package
(name "r-abtest")
- (version "0.2.0")
+ (version "0.2.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "abtest" version))
(sha256
(base32
- "1ky3cf827kj24bhcpk00v5zl5jdkii1gca0x81ay1cjkzfispgws"))))
+ "1zfd13d7dplawk24dbdr1ka8cbdp5w6sxb0zlm7k4dhvn6ksi8h0"))))
(properties `((upstream-name . "abtest")))
(build-system r-build-system)
(propagated-inputs
`(("r-matrix" ,r-matrix)
("r-mvtnorm" ,r-mvtnorm)
("r-plotrix" ,r-plotrix)
+ ("r-qgam" ,r-qgam)
("r-rcolorbrewer" ,r-rcolorbrewer)
("r-rcpp" ,r-rcpp)
("r-sn" ,r-sn)
- ("r-truncnorm" ,r-truncnorm)
- ("r-vgam" ,r-vgam)))
+ ("r-truncnorm" ,r-truncnorm)))
(home-page "https://cran.r-project.org/web/packages/abtest/")
(synopsis "Bayesian A/B testing")
(description
@@ -18107,14 +18333,14 @@ actigraphy-measured activity counts data.")
(define-public r-fda
(package
(name "r-fda")
- (version "2.4.8.1")
+ (version "5.1.4")
(source
(origin
(method url-fetch)
(uri (cran-uri "fda" version))
(sha256
(base32
- "0g50kj1dx7zarjv0lgwyzd2c7bv6di7nkndmywday5vjywgl8m7a"))))
+ "0js4ggl3aiwsqk6npwz72yhcznkb63smddds24ngf6a0p8yp5p2x"))))
(properties `((upstream-name . "fda")))
(build-system r-build-system)
(propagated-inputs
@@ -18569,14 +18795,14 @@ functions.")
(define-public r-univoutl
(package
(name "r-univoutl")
- (version "0.1-5")
+ (version "0.2")
(source
(origin
(method url-fetch)
(uri (cran-uri "univOutl" version))
(sha256
(base32
- "193wrpkvgmlrx43nag8w3ivrlqm37nm6g86wcvd3bgw3hchs70gi"))))
+ "0rlc3w7cx2hfxacpjs9kmjzv5p8v9wxnlpxi3rh276wiy5zdr91v"))))
(properties `((upstream-name . "univOutl")))
(build-system r-build-system)
(propagated-inputs
@@ -19513,17 +19739,20 @@ character codes as well as the UN M.49 area codes.")
(define-public r-stopwords
(package
(name "r-stopwords")
- (version "1.0")
+ (version "2.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "stopwords" version))
(sha256
(base32
- "1nmi0bpd0c238g5b8ch1v034m5ng9llhs519cgxdrj3sh9fplwlv"))))
+ "155g00ansyqfpp1mzd2q6mn0k214xinf78nww2368h24kz761jjw"))))
(properties `((upstream-name . "stopwords")))
(build-system r-build-system)
- (propagated-inputs `(("r-isocodes" ,r-isocodes)))
+ (propagated-inputs
+ `(("r-desc" ,r-desc)
+ ("r-isocodes" ,r-isocodes)
+ ("r-usethis" ,r-usethis)))
(home-page "https://github.com/quanteda/stopwords")
(synopsis "Multilingual stopword lists")
(description
@@ -19627,14 +19856,14 @@ machine learning, visually representing text and text analyses, and more.")
(define-public r-topicmodels
(package
(name "r-topicmodels")
- (version "0.2-9")
+ (version "0.2-11")
(source
(origin
(method url-fetch)
(uri (cran-uri "topicmodels" version))
(sha256
(base32
- "1757r5x8bsl4dk106xg6481mvdkdz9vwg87n7rpbvdkavsvhyxs0"))))
+ "0jmp6wva99y0w40cfw7b0faylndhjam097x36ilc4vmyczcv89lw"))))
(properties `((upstream-name . "topicmodels")))
(build-system r-build-system)
(native-inputs
@@ -19990,19 +20219,18 @@ estimate parameters given observed data.")
(define-public r-kutils
(package
(name "r-kutils")
- (version "1.69")
+ (version "1.70")
(source
(origin
(method url-fetch)
(uri (cran-uri "kutils" version))
(sha256
(base32
- "12pg26a85h0jxlfcyai68dbh4bq1gnq8v1ngi8k9qvafbrpc6gx8"))))
+ "06jk66wbq3jmdf2jdhqns6r3yk36l2x7c907x977zv80sqxa1l37"))))
(properties `((upstream-name . "kutils")))
(build-system r-build-system)
(propagated-inputs
`(("r-foreign" ,r-foreign)
- ("r-lavaan" ,r-lavaan)
("r-openxlsx" ,r-openxlsx)
("r-plyr" ,r-plyr)
("r-runit" ,r-runit)
@@ -21404,3 +21632,40 @@ infinite-precision rational arithmetic.")
Archive Toolkit. Rxnat uses the XNAT REST API to perform data queries and
download images.")
(license license:gpl2)))
+
+(define-public r-rserve
+ (package
+ (name "r-rserve")
+ (version "1.8-6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.rforge.net/Rserve/snapshot/Rserve_"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "017kkzv9lxlz9qhg3gprrf1wcyflxrif6wjk27x9b4bdzylw6bsx"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-checkmate" ,r-checkmate)
+ ("r-mime" ,r-mime)
+ ("r-jsonlite" ,r-jsonlite)
+ ("r-knitr" ,r-knitr)
+ ("r-r6" ,r-r6)
+ ("r-rcpp" ,r-rcpp)
+ ("r-uuid" ,r-uuid)))
+ (inputs
+ `(("openssl" ,openssl)
+ ("zlib" ,zlib)))
+ (home-page "https://github.com/s-u/Rserve")
+ (synopsis
+ "Server providing access to R from many languages and systems")
+ (description
+ "Rserve acts as a socket server (TCP/IP or local sockets) which allows
+binary requests to be sent to R. Every connection has a separate workspace
+and working directory. Client-side implementations are available for popular
+languages such as C/C++ and Java, allowing any application to use facilities
+of R without the need of linking to R code. Rserve supports remote
+connection, user authentication and file transfer. A simple R client is
+included in this package as well.")
+ (license license:gpl2)))