aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm782
1 files changed, 781 insertions, 1 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index feae801116..bb7576352f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -21,7 +21,12 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix utils)
- #:use-module (guix build-system r))
+ #:use-module (guix build-system r)
+ #:use-module (gnu packages gcc)
+ #:use-module (gnu packages maths)
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages statistics)
+ #:use-module (gnu packages web))
(define-public r-colorspace
(package
@@ -148,3 +153,778 @@ where the bound function accepts additional arguments.")
"This package provides an easy way to fill an environment with active
bindings that call a C++ function.")
(license license:expat)))
+
+(define-public r-auc
+ (package
+ (name "r-auc")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "AUC" version))
+ (sha256
+ (base32
+ "0ripcib2qz0m7rgr1kiz68nx8f6p408l1ww7j78ljqik7p3g41g7"))))
+ (properties `((upstream-name . "AUC")))
+ (build-system r-build-system)
+ (home-page "http://cran.r-project.org/web/packages/AUC")
+ (synopsis "Compute the area under the curve of selected measures")
+ (description
+ "This package includes functions to compute the area under the curve of
+selected measures: the area under the sensitivity curve (AUSEC), the area
+under the specificity curve (AUSPC), the area under the accuracy
+curve (AUACC), and the area under the receiver operating characteristic
+curve (AUROC). The curves can also be visualized. Support for partial areas
+is provided.")
+ (license license:gpl2+)))
+
+(define-public r-calibrate
+ (package
+ (name "r-calibrate")
+ (version "1.7.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "calibrate" version))
+ (sha256
+ (base32
+ "010nb1nb9y7zhw2k6d2i2drwy5brp7b83mjj2w7i3wjp9xb6l1kq"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-mass" ,r-mass)))
+ (home-page "http://cran.r-project.org/web/packages/calibrate")
+ (synopsis "Calibration of scatterplot and biplot axes")
+ (description
+ "This is a package for drawing calibrated scales with tick marks
+on (non-orthogonal) variable vectors in scatterplots and biplots.")
+ (license license:gpl2)))
+
+(define-public r-shape
+ (package
+ (name "r-shape")
+ (version "1.4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "shape" version))
+ (sha256
+ (base32
+ "0yk3cmsa57svcvbnm21pyr0s0qbhnllka8nmsg4yb41frjlqph66"))))
+ (build-system r-build-system)
+ (home-page "http://cran.r-project.org/web/packages/shape")
+ (synopsis "Functions for plotting graphical shapes")
+ (description
+ "This package provides functions for plotting graphical shapes such as
+ellipses, circles, cylinders, arrows, ...")
+ (license license:gpl3+)))
+
+(define-public r-globaloptions
+ (package
+ (name "r-globaloptions")
+ (version "0.0.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "GlobalOptions" version))
+ (sha256
+ (base32
+ "1abpc03cfvazbwj2sx6qgngs5pgpzysvxkana20hyvb4n7ws77f0"))))
+ (properties `((upstream-name . "GlobalOptions")))
+ (build-system r-build-system)
+ (home-page "https://github.com/jokergoo/GlobalOptions")
+ (synopsis "Generate functions to get or set global options")
+ (description
+ "This package provides more controls on the option values such as
+validation and filtering on the values, making options invisible or private.")
+ (license license:gpl2+)))
+
+(define-public r-circlize
+ (package
+ (name "r-circlize")
+ (version "0.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "circlize" version))
+ (sha256
+ (base32
+ "0p1zx1aawkblz48kzzfn5w1k3lbwv9wrk1k5gcfjrr2b4sz1pp5b"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-colorspace" ,r-colorspace)
+ ("r-globaloptions" ,r-globaloptions)
+ ("r-shape" ,r-shape)))
+ (home-page "https://github.com/jokergoo/circlize")
+ (synopsis "Circular visualization")
+ (description
+ "Circular layout is an efficient way for the visualization of huge
+amounts of information. This package provides an implementation of circular
+layout generation in R as well as an enhancement of available software. The
+flexibility of the package is based on the usage of low-level graphics
+functions such that self-defined high-level graphics can be easily implemented
+by users for specific purposes. Together with the seamless connection between
+the powerful computational and visual environment in R, it gives users more
+convenience and freedom to design figures for better understanding complex
+patterns behind multiple dimensional data.")
+ (license license:gpl2+)))
+
+(define-public r-powerlaw
+ (package
+ (name "r-powerlaw")
+ (version "0.70.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "poweRlaw" version))
+ (sha256
+ (base32
+ "1p2la3hslxq2xa8jkwvci6zcpn47cvyr9xqd5agp1riwwp2xw5gh"))))
+ (properties `((upstream-name . "poweRlaw")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-vgam" ,r-vgam)))
+ (home-page "https://github.com/csgillespie/poweRlaw")
+ (synopsis "Tools for the analysis of heavy tailed distributions")
+ (description
+ "This package provides an implementation of maximum likelihood estimators
+for a variety of heavy tailed distributions, including both the discrete and
+continuous power law distributions. Additionally, a goodness-of-fit based
+approach is used to estimate the lower cut-off for the scaling region.")
+ ;; Any of these GPL versions.
+ (license (list license:gpl2 license:gpl3))))
+
+(define-public r-compare
+ (package
+ (name "r-compare")
+ (version "0.2-6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "compare" version))
+ (sha256
+ (base32
+ "0k9zms930b5dz9gy8414li21wy0zg9x9vp7301v5cvyfi0g7xzgw"))))
+ (build-system r-build-system)
+ (home-page "http://cran.r-project.org/web/packages/compare")
+ (synopsis "Comparing objects for differences")
+ (description
+ "This package provides functions to compare a model object to a
+comparison object. If the objects are not identical, the functions can be
+instructed to explore various modifications of the objects (e.g., sorting
+rows, dropping names) to see if the modified versions are identical.")
+ (license license:gpl2+)))
+
+(define-public r-dendextend
+ (package
+ (name "r-dendextend")
+ (version "1.5.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "dendextend" version))
+ (sha256
+ (base32
+ "04jz58apibfrkjcrdmw2hmsav6qpb5cs6qdai81k1v1iznfcya42"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-fpc" ,r-fpc)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-magrittr" ,r-magrittr)
+ ("r-viridis" ,r-viridis)
+ ("r-whisker" ,r-whisker)))
+ (home-page "https://cran.r-project.org/web/packages/dendextend")
+ (synopsis "Extending 'dendrogram' functionality in R")
+ (description
+ "This package offers a set of functions for extending @code{dendrogram}
+objects in R, letting you visualize and compare trees of hierarchical
+clusterings. You can adjust a tree's graphical parameters (the color, size,
+type, etc of its branches, nodes and labels) and visually and statistically
+compare different dendrograms to one another.")
+ ;; Any of these versions
+ (license (list license:gpl2 license:gpl3))))
+
+(define-public r-getoptlong
+ (package
+ (name "r-getoptlong")
+ (version "0.1.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "GetoptLong" version))
+ (sha256
+ (base32
+ "1d98gcvlvp9nz5lbnzr0kkpc2hbkx74hlhrnybqhg1gdwc3g09pm"))))
+ (properties `((upstream-name . "GetoptLong")))
+ (build-system r-build-system)
+ (inputs
+ `(("perl" ,perl)))
+ (propagated-inputs
+ `(("r-globaloptions" ,r-globaloptions)
+ ("r-rjson" ,r-rjson)))
+ (home-page "https://github.com/jokergoo/GetoptLong")
+ (synopsis "Parsing command-line arguments and variable interpolation")
+ (description
+ "This is yet another command-line argument parser which wraps the
+powerful Perl module @code{Getopt::Long} and with some adaptation for easier
+use in R. It also provides a simple way for variable interpolation in R.")
+ (license license:gpl2+)))
+
+(define-public r-fastmatch
+ (package
+ (name "r-fastmatch")
+ (version "1.1-0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "fastmatch" version))
+ (sha256
+ (base32
+ "0z80jxkygmzn11sq0c2iz357s9bpki548lg926g85gldhfj1md90"))))
+ (build-system r-build-system)
+ (home-page "http://www.rforge.net/fastmatch")
+ (synopsis "Fast match function")
+ (description
+ "This package provides a fast @code{match} replacement for cases that
+require repeated look-ups. It is slightly faster that R's built-in
+@code{match} function on first match against a table, but extremely fast on
+any subsequent lookup as it keeps the hash table in memory.")
+ (license license:gpl2)))
+
+(define-public r-ff
+ (package
+ (name "r-ff")
+ (version "2.2-13")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ff" version))
+ (sha256
+ (base32
+ "1nvd6kx46xzyc99a44mgynd94pvd2h495m5a7b1g67k5w2phiywb"))))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-bit" ,r-bit)))
+ (home-page "http://ff.r-forge.r-project.org/")
+ (synopsis "Memory-efficient storage of large data on disk and access functions")
+ (description
+ "This package provides data structures that are stored on disk but
+behave (almost) as if they were in RAM by transparently mapping only a section
+in main memory.")
+ (license license:gpl2)))
+
+(define-public r-ffbase
+ (package
+ (name "r-ffbase")
+ (version "0.12.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ffbase" version))
+ (sha256
+ (base32
+ "1nz97bndxxkzp8rq6va8ff5ky9vkaib1jybm6j852awwb3n9had5"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-bit" ,r-bit)
+ ("r-fastmatch" ,r-fastmatch)
+ ("r-ff" ,r-ff)))
+ (home-page "http://github.com/edwindj/ffbase")
+ (synopsis "Basic statistical functions for package 'ff'")
+ (description
+ "This package extends the out of memory vectors of @code{ff} with
+statistical functions and other utilities to ease their usage.")
+ (license license:gpl3)))
+
+(define-public r-prettyunits
+ (package
+ (name "r-prettyunits")
+ (version "1.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "prettyunits" version))
+ (sha256
+ (base32
+ "0p3z42hnk53x7ky4d1dr2brf7p8gv3agxr71i99m01n2hq2ri91m"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-assertthat" ,r-assertthat)
+ ("r-magrittr" ,r-magrittr)))
+ (home-page "https://github.com/gaborcsardi/prettyunits")
+ (synopsis "Pretty, human readable formatting of quantities")
+ (description
+ "This package provides tools for pretty, human readable formatting of
+quantities.")
+ (license license:expat)))
+
+(define-public r-reshape
+ (package
+ (name "r-reshape")
+ (version "0.8.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "reshape" version))
+ (sha256
+ (base32
+ "1f1ngalc22knhdm9djv1m6abnjqpv1frdzxfkpakhph2l67bk7fq"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-plyr" ,r-plyr)
+ ("r-rcpp" ,r-rcpp)))
+ (home-page "http://had.co.nz/reshape")
+ (synopsis "Flexibly reshape data")
+ (description
+ "Flexibly restructure and aggregate data using just two functions:
+@code{melt} and @code{cast}. This package provides them.")
+ (license license:expat)))
+
+(define-public r-progress
+ (package
+ (name "r-progress")
+ (version "1.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "progress" version))
+ (sha256
+ (base32
+ "1fxakchfjr5vj59s9sxynd7crpz97xj42438rmkhkf3rjpyspx59"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-prettyunits" ,r-prettyunits)
+ ("r-r6" ,r-r6)))
+ (home-page "https://github.com/gaborcsardi/progress")
+ (synopsis "Terminal progress bars")
+ (description
+ "This package provides configurable progress bars. They may include
+percentage, elapsed time, and/or the estimated completion time. They work in
+terminals, in Emacs ESS, RStudio, Windows Rgui, and the macOS R.app. The
+package also provides a C++ API, that works with or without Rcpp.")
+ (license license:expat)))
+
+(define-public r-ggally
+ (package
+ (name "r-ggally")
+ (version "1.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "GGally" version))
+ (sha256
+ (base32
+ "12ddab0nd0f9c7bb6cx3c22mliyvc8xsxv26aqz3cvfbla8crp3b"))))
+ (properties `((upstream-name . "GGally")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-gtable" ,r-gtable)
+ ("r-plyr" ,r-plyr)
+ ("r-progress" ,r-progress)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)
+ ("r-reshape" ,r-reshape)))
+ (home-page "https://ggobi.github.io/ggally")
+ (synopsis "Extension to ggplot2")
+ (description
+ "The R package ggplot2 is a plotting system based on the grammar of
+graphics. GGally extends ggplot2 by adding several functions to reduce the
+complexity of combining geometric objects with transformed data. Some of
+these functions include a pairwise plot matrix, a two group pairwise plot
+matrix, a parallel coordinates plot, a survival plot, and several functions to
+plot networks.")
+ (license license:gpl2+)))
+
+(define-public r-proxy
+ (package
+ (name "r-proxy")
+ (version "0.4-17")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "proxy" version))
+ (sha256
+ (base32
+ "0bg1fn96qrj8whmnl7c3gv244ksm2ykxxsd0zrmw4lb6465pizl2"))))
+ (build-system r-build-system)
+ (home-page "http://cran.r-project.org/web/packages/proxy")
+ (synopsis "Distance and similarity measures")
+ (description
+ "This package provides an extensible framework for the efficient
+calculation of auto- and cross-proximities, along with implementations of the
+most popular ones.")
+ (license license:gpl2)))
+
+(define-public r-sp
+ (package
+ (name "r-sp")
+ (version "1.2-4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "sp" version))
+ (sha256
+ (base32
+ "0crba3j00mb2xv2yk60rpa57gn97xq4ql3a6p9cjzqjxzv2cknk2"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-lattice" ,r-lattice)))
+ (home-page "http://cran.r-project.org/web/packages/sp")
+ (synopsis "Classes and methods for spatial data")
+ (description
+ "This package provides classes and methods for spatial data; the classes
+document where the spatial location information resides, for 2D or 3D data.
+Utility functions are provided, e.g. for plotting data as maps, spatial
+selection, as well as methods for retrieving coordinates, for subsetting,
+print, summary, etc.")
+ (license license:gpl2+)))
+
+(define-public r-rmtstat
+ (package
+ (name "r-rmtstat")
+ (version "0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "RMTstat" version))
+ (sha256
+ (base32
+ "1nn25q4kmh9kj975sxkrpa97vh5irqrlqhwsfinbck6h6ia4rsw1"))))
+ (properties `((upstream-name . "RMTstat")))
+ (build-system r-build-system)
+ (home-page "http://cran.r-project.org/web/packages/RMTstat")
+ (synopsis "Distributions, statistics and tests derived from random matrix theory")
+ (description
+ "This package provides functions for working with the Tracy-Widom laws
+and other distributions related to the eigenvalues of large Wishart
+matrices.")
+ (license license:bsd-3)))
+
+(define-public r-lmoments
+ (package
+ (name "r-lmoments")
+ (version "1.2-3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "Lmoments" version))
+ (sha256
+ (base32
+ "13p0r4w16jvjnyjmkhkp3dwdfr1gap2l0k4k5jy41m8nc5fvcx79"))))
+ (properties `((upstream-name . "Lmoments")))
+ (build-system r-build-system)
+ (home-page "http://www.tilastotiede.fi/juha_karvanen.html")
+ (synopsis "L-moments and quantile mixtures")
+ (description
+ "This package contains functions to estimate L-moments and trimmed
+L-moments from the data. It also contains functions to estimate the
+parameters of the normal polynomial quantile mixture and the Cauchy polynomial
+quantile mixture from L-moments and trimmed L-moments.")
+ (license license:gpl2)))
+
+(define-public r-distillery
+ (package
+ (name "r-distillery")
+ (version "1.0-2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "distillery" version))
+ (sha256
+ (base32
+ "12m4cacvc18fd3aayc8iih5q6bwsmvf29b55fwp7vs8wp1h8nd8c"))))
+ (build-system r-build-system)
+ (home-page "http://www.ral.ucar.edu/staff/ericg")
+ (synopsis "Functions for confidence intervals and object information")
+ (description
+ "This package provides some very simple method functions for confidence
+interval calculation and to distill pertinent information from a potentially
+complex object; primarily used in common with the packages extRemes and
+SpatialVx.")
+ (license license:gpl2+)))
+
+(define-public r-extremes
+ (package
+ (name "r-extremes")
+ (version "2.0-8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "extRemes" version))
+ (sha256
+ (base32
+ "0pnpib3g2r9x8hfqhvq23j8m3jh62lp28ipnqir5yadnzv850gfm"))))
+ (properties `((upstream-name . "extRemes")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-car" ,r-car)
+ ("r-distillery" ,r-distillery)
+ ("r-lmoments" ,r-lmoments)))
+ (home-page "http://www.assessment.ucar.edu/toolkit/")
+ (synopsis "Extreme value analysis")
+ (description
+ "ExtRemes is a suite of functions for carrying out analyses on the
+extreme values of a process of interest; be they block maxima over long blocks
+or excesses over a high threshold.")
+ (license license:gpl2+)))
+
+(define-public r-lmtest
+ (package
+ (name "r-lmtest")
+ (version "0.9-35")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "lmtest" version))
+ (sha256
+ (base32
+ "107br1l7p52wxvazs031f4h5ryply97qywg9dzrkw4ydnvqq4j9g"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-zoo" ,r-zoo)))
+ (native-inputs
+ `(("gfortran" ,gfortran)))
+ (home-page "http://cran.r-project.org/web/packages/lmtest")
+ (synopsis "Testing linear regression models")
+ (description
+ "This package provides a collection of tests, data sets, and examples for
+diagnostic checking in linear regression models. Furthermore, some generic
+tools for inference in parametric models are provided.")
+ ;; Either version is okay
+ (license (list license:gpl2 license:gpl3))))
+
+(define-public r-inline
+ (package
+ (name "r-inline")
+ (version "0.3.14")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "inline" version))
+ (sha256
+ (base32
+ "0cf9vya9h4znwgp6s1nayqqmh6mwyw7jl0isk1nx4j2ijszxcd7x"))))
+ (build-system r-build-system)
+ (home-page "http://cran.r-project.org/web/packages/inline")
+ (synopsis "Functions to inline C, C++, Fortran function calls from R")
+ (description
+ "This package provides functionality to dynamically define R functions
+and S4 methods with inlined C, C++ or Fortran code supporting @code{.C} and
+@code{.Call} calling conventions.")
+ ;; Any version of the LGPL.
+ (license license:lgpl3+)))
+
+(define-public r-bbmle
+ (package
+ (name "r-bbmle")
+ (version "1.0.19")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "bbmle" version))
+ (sha256
+ (base32
+ "014h6mw16gv4acs2p78dy7lla7s428n633aybsb1mbi6250dg0p8"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-lattice" ,r-lattice)
+ ("r-mass" ,r-mass)
+ ("r-numderiv" ,r-numderiv)))
+ (home-page "http://cran.r-project.org/web/packages/bbmle")
+ (synopsis "Tools for General Maximum Likelihood Estimation")
+ (description
+ "Methods and functions for fitting maximum likelihood models in R. This
+package modifies and extends the @code{mle} classes in the @code{stats4}
+package.")
+ ;; Any version of the GPL
+ (license (list license:gpl2 license:gpl3))))
+
+(define-public r-emdbook
+ (package
+ (name "r-emdbook")
+ (version "1.3.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "emdbook" version))
+ (sha256
+ (base32
+ "09xbdyw8a4pvrsg3ryr8drby0njy4avc5wsjj4ffibdaicpchy69"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-bbmle" ,r-bbmle)
+ ("r-coda" ,r-coda)
+ ("r-lattice" ,r-lattice)
+ ("r-mass" ,r-mass)
+ ("r-plyr" ,r-plyr)
+ ("r-rcpp" ,r-rcpp)))
+ (home-page "http://www.math.mcmaster.ca/bolker/emdbook")
+ (synopsis "Support functions and data for \"Ecological Models and Data\"")
+ (description
+ "This package provides auxiliary functions and data sets for \"Ecological
+Models and Data\", a book presenting maximum likelihood estimation and related
+topics for ecologists (ISBN 978-0-691-12522-0).")
+ ;; Any GPL version
+ (license (list license:gpl2 license:gpl3))))
+
+(define-public r-lpsolve
+ (package
+ (name "r-lpsolve")
+ (version "5.6.13")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "lpSolve" version))
+ (sha256
+ (base32
+ "13a9ry8xf5j1f2j6imqrxdgxqz3nqp9sj9b4ivyx9sid459irm6m"))))
+ (properties `((upstream-name . "lpSolve")))
+ (build-system r-build-system)
+ (home-page "http://cran.r-project.org/web/packages/lpSolve")
+ (synopsis "R interface to Lp_solve to solve linear/integer programs")
+ (description
+ "Lp_solve is software for solving linear, integer and mixed integer
+programs. This implementation supplies a \"wrapper\" function in C and some R
+functions that solve general linear/integer problems, assignment problems, and
+transportation problems.")
+ (license license:lgpl2.0)))
+
+(define-public r-limsolve
+ (package
+ (name "r-limsolve")
+ (version "1.5.5.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "limSolve" version))
+ (sha256
+ (base32
+ "1ll6ir42h3g2fzf0wqai213bm82gpwjj2hfma2np3mz024sc09rg"))))
+ (properties `((upstream-name . "limSolve")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-lpsolve" ,r-lpsolve)
+ ("r-mass" ,r-mass)
+ ("r-quadprog" ,r-quadprog)))
+ (native-inputs `(("gfortran" ,gfortran)))
+ (home-page "http://cran.r-project.org/web/packages/limSolve")
+ (synopsis "Solving linear inverse models")
+ (description
+ "This package provides functions that:
+
+@enumerate
+@item find the minimum/maximum of a linear or quadratic function,
+@item sample an underdetermined or overdetermined system,
+@item solve a linear system Ax=B for the unknown x.
+@end enumerate
+
+It includes banded and tridiagonal linear systems. The package calls Fortran
+functions from LINPACK.")
+ ;; Any GPL version.
+ (license (list license:gpl2+ license:gpl3+))))
+
+(define-public r-fitdistrplus
+ (package
+ (name "r-fitdistrplus")
+ (version "1.0-9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "fitdistrplus" version))
+ (sha256
+ (base32
+ "18x9454g598d54763k3hvi33iszifk7sxvhd1zg5r8z1vpixx3z6"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-mass" ,r-mass)
+ ("r-survival" ,r-survival)))
+ (home-page "http://riskassessment.r-forge.r-project.org")
+ (synopsis "Fitting a parametric distribution from data")
+ (description
+ "This package extends the @code{fitdistr} function of the MASS package
+with several functions to help the fit of a parametric distribution to
+non-censored or censored data. Censored data may contain left-censored,
+right-censored and interval-censored values, with several lower and upper
+bounds. In addition to @dfn{maximum likelihood estimation} (MLE), the package
+provides moment matching (MME), quantile matching (QME) and maximum
+goodness-of-fit estimation (MGE) methods (available only for non-censored
+data). Weighted versions of MLE, MME and QME are available.")
+ (license license:gpl2+)))
+
+(define-public r-energy
+ (package
+ (name "r-energy")
+ (version "1.7-0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "energy" version))
+ (sha256
+ (base32
+ "1g4hqi6mgsnd1w4q7dd2m40ljh2jdmvad91ksbq9fscnrqpvji1x"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-boot" ,r-boot)
+ ("r-rcpp" ,r-rcpp)))
+ (home-page "http://cran.r-project.org/web/packages/energy")
+ (synopsis "Multivariate inference via the energy of data")
+ (description
+ "This package provides e-statistics (energy) tests and statistics for
+multivariate and univariate inference, including distance correlation,
+one-sample, two-sample, and multi-sample tests for comparing multivariate
+distributions, are implemented. Measuring and testing multivariate
+independence based on distance correlation, partial distance correlation,
+multivariate goodness-of-fit tests, clustering based on energy distance,
+testing for multivariate normality, distance components (disco) for
+non-parametric analysis of structured data, and other energy
+statistics/methods are implemented.")
+ (license license:gpl2+)))
+
+(define-public r-suppdists
+ (package
+ (name "r-suppdists")
+ (version "1.1-9.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "SuppDists" version))
+ (sha256
+ (base32
+ "1ffx8wigqqvz2pnh06jjc0fnf4vq9z2rhwk2y3f9aszn18ap3dgw"))))
+ (properties `((upstream-name . "SuppDists")))
+ (build-system r-build-system)
+ (home-page "http://cran.r-project.org/web/packages/SuppDists")
+ (synopsis "Supplementary distributions")
+ (description
+ "This package provides ten distributions supplementing those built into
+R. Inverse Gauss, Kruskal-Wallis, Kendall's Tau, Friedman's chi squared,
+Spearman's rho, maximum F ratio, the Pearson product moment correlation
+coefficient, Johnson distributions, normal scores and generalized
+hypergeometric distributions. In addition two random number generators of
+George Marsaglia are included.")
+ (license license:gpl2+)))
+
+(define-public r-ksamples
+ (package
+ (name "r-ksamples")
+ (version "1.2-6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "kSamples" version))
+ (sha256
+ (base32
+ "1pbam0zqq44slpxdgl2s2fsfdgl7i0pgm8bzlvnm0fy0na24bgdj"))))
+ (properties `((upstream-name . "kSamples")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-suppdists" ,r-suppdists)))
+ (home-page "http://cran.r-project.org/web/packages/kSamples")
+ (synopsis "K-Sample rank tests and their combinations")
+ (description
+ "This package provides tools to compares k samples using the
+Anderson-Darling test, Kruskal-Wallis type tests with different rank score
+criteria, Steel's multiple comparison test, and the Jonckheere-Terpstra (JT)
+test. It computes asymptotic, simulated or (limited) exact P-values, all
+valid under randomization, with or without ties, or conditionally under random
+sampling from populations, given the observed tie pattern. Except for Steel's
+test and the JT test it also combines these tests across several blocks of
+samples.")
+ (license license:gpl2+)))