aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/conky.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/conky.scm')
-rw-r--r--gnu/packages/conky.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/conky.scm b/gnu/packages/conky.scm
index 2b32bf8791..046d132a9b 100644
--- a/gnu/packages/conky.scm
+++ b/gnu/packages/conky.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2015 Siniša Biđin <sinisa@bidin.eu>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2019 Vasile Dumitrascu <va511e@yahoo.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -31,13 +32,14 @@
#:use-module (gnu packages lua)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages pulseaudio)
#:use-module (gnu packages xorg))
(define-public conky
(package
(name "conky")
(home-page "https://github.com/brndnmtthws/conky")
- (version "1.11.3")
+ (version "1.11.5")
(source
(origin
(method git-fetch)
@@ -46,12 +48,13 @@
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0pdl31xvmy8niagzqx9sd2b6hc6lzwfiaz66m4djf1gz9bksc8qv"))))
+ (base32 "1a75ss48mn9pknrxy33dh5rdgm67a5kpddsyqfhlcn1761kfzzyp"))))
(build-system cmake-build-system)
(arguments
- `(#:tests? #f ; there are no tests
+ `(#:tests? #f ; there are no tests
#:configure-flags
- (list "-DRELEASE=true")
+ (list "-DRELEASE=true"
+ "-DBUILD_PULSEAUDIO=ON")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'add-freetype-to-search-path
@@ -76,6 +79,7 @@
("libxext" ,libxext)
("libxft" ,libxft)
("libxinerama" ,libxinerama)
+ ("pulseaudio", pulseaudio)
("lua" ,lua)
("ncurses" ,ncurses)
("curl" ,curl)))