aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 7286e954c5..c38f40f618 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -66,6 +66,15 @@
;;; To avoid circular dependencies, this module should not be imported
;;; directly from anywhere.
;;;
+;;; Below, we frequently use "inherit" to create modified packages. The
+;;; reason why we use "inherit" instead of "package/inherit" is because we do
+;;; not want these commencement packages to inherit grafts. By definition,
+;;; these packages are not depended on at run time by any of the packages we
+;;; use. Thus it does not make sense to inherit grafts. Furthermore, those
+;;; grafts would often lead to extra overhead for users who would end up
+;;; downloading those "-boot0" packages just to build package replacements
+;;; that are in fact not going to be used.
+;;;
;;; Code:
(define gnu-make-boot0