aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cluster.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cluster.scm')
-rw-r--r--gnu/packages/cluster.scm18
1 files changed, 6 insertions, 12 deletions
diff --git a/gnu/packages/cluster.scm b/gnu/packages/cluster.scm
index 7cfd04f008..faaaa2419a 100644
--- a/gnu/packages/cluster.scm
+++ b/gnu/packages/cluster.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Sou Bunnbu <iyzsong@member.fsf.org>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -30,7 +31,7 @@
(define-public keepalived
(package
(name "keepalived")
- (version "2.0.1")
+ (version "2.0.4")
(source (origin
(method url-fetch)
(uri (string-append
@@ -38,18 +39,11 @@
version ".tar.gz"))
(sha256
(base32
- "0hp8i56zkf0398bmpi32a85f05cv2fy9wizkdfbxk7gav4z6yx18"))))
+ "0qf46bfxv4w7qx7d73qq26pp72cvbyfjvna3hxn208vynvapalh0"))))
(build-system gnu-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
- (add-before 'configure 'patch-configure
- (lambda _
- ;; XXX: The 'configure' script doesn't handle '-L' flags in the
- ;; output of 'pkg-config'.
- (substitute* "configure"
- (("PKG_CONFIG --libs") "PKG_CONFIG --libs-only-l"))
- #t))
(add-after 'build 'build-info
(lambda _
(invoke "make" "-C" "doc" "texinfo")
@@ -77,11 +71,11 @@
("libnfnetlink" ,libnfnetlink)
("libnl" ,libnl)))
(home-page "http://www.keepalived.org/")
- (synopsis "Loadbalancing and high-availability frameworks")
+ (synopsis "Load balancing and high-availability frameworks")
(description
"Keepalived provides frameworks for both load balancing and high
availability. The load balancing framework relies on the Linux Virtual
-Server (IPVS) kernel module. High availability is achieved by the Virtual
-Redundancy Routing Protocol (VRRP). Each Keepalived framework can be used
+Server (@dfn{IPVS}) kernel module. High availability is achieved by the Virtual
+Redundancy Routing Protocol (@dfn{VRRP}). Each Keepalived framework can be used
independently or together to provide resilient infrastructures.")
(license license:gpl2+)))