aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/c.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/c.scm')
-rw-r--r--gnu/packages/c.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 1b168d2ca8..d13b62b5e2 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -641,6 +641,28 @@ be a separate step, and tokenization rules can be written in the same way as
any other grammar rules.")
(license license:expat)))
+(define-public sfsexp
+ (package
+ (name "sfsexp")
+ (version "1.4.1")
+ (home-page "https://github.com/mjsottile/sfsexp")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03srnpc7p1j7ygd0wx9gybcxhqm50kjzkybh1xs75nwz97q3y2dq"))))
+ (build-system gnu-build-system)
+ (native-inputs (list autoconf automake libtool))
+ (synopsis "Symbolic expression library for C and C++")
+ (description
+ "sfsexp is a C/C++ library to read, parse, modify, and create symbolic
+expressions.")
+ (license license:lgpl2.1+)))
+
(define-public sparse
(package
(name "sparse")