aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bittorrent.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bittorrent.scm')
-rw-r--r--gnu/packages/bittorrent.scm13
1 files changed, 1 insertions, 12 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index e8aedd74c3..43712d4bcf 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -400,18 +400,7 @@ and will take advantage of multiple processor cores where possible.")
"--enable-tests")
#:make-flags (list
(string-append "LDFLAGS=-Wl,-rpath="
- (assoc-ref %outputs "out") "/lib"))
- #:phases (modify-phases %standard-phases
- (add-after 'unpack 'compile-python-c++11
- (lambda _
- ;; Make sure the Python bindings are compiled in C++ mode to
- ;; avoid undefined references as mentioned in
- ;; <https://github.com/qbittorrent/qBittorrent/issues/638>.
- ;; XXX: This can be removed for 1.2+.
- (substitute* "bindings/python/setup.py"
- (("\\+ target_specific\\(\\)\\,")
- "+ target_specific() + ['-std=c++11'],"))
- #t)))))
+ (assoc-ref %outputs "out") "/lib"))))
(inputs `(("boost" ,boost)
("openssl" ,openssl)))
(native-inputs `(("python" ,python-2)