aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm21
1 files changed, 20 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 477ad60f71..3c0366814b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2133,7 +2133,19 @@ data and settings.")
(base32
"0rah9ja4m0rl5mldd6vag9rwrivw1zrqxssfq8qx64m7961fp68k"))))
(build-system cmake-build-system)
- (arguments `(#:tests? #f)) ; there are no tests
+ (arguments
+ `(#:tests? #f ; there are no tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'add-missing-includes
+ (lambda _
+ (substitute* "src/executioninformation.hpp"
+ (("#define EXECUTIONINFORMATION_HPP" line)
+ (string-append line "\n#include <random>")))
+ (substitute* "src/plasma/fasta.hpp"
+ (("#define FASTA_HPP" line)
+ (string-append line "\n#include <random>")))
+ #t)))))
(inputs
`(("boost" ,boost)
("cairo" ,cairo)))
@@ -5210,6 +5222,13 @@ against local background noises.")
(("#include \"(bam|sam|kstring).h\"" _ header)
(string-append "#include <samtools/" header ".h>")))
#t))
+ (add-after 'unpack 'remove-duplicate-typedef
+ (lambda _
+ ;; This typedef conflicts with the typedef in
+ ;; glibc-2.25/include/bits/types.h
+ (substitute* "gclib/GThreads.h"
+ (("typedef long long __intmax_t;") ""))
+ #t))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((bin (string-append (assoc-ref outputs "out") "/bin/")))