aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm45
1 files changed, 22 insertions, 23 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9a04118588..a99deeb0a6 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2537,31 +2537,30 @@ similarity of community members.")
(delete 'configure)
(replace 'build
(lambda* (#:key source #:allow-other-keys)
- (and (zero? (system* "gcc"
- "-O3"
- "-finline-functions"
- "-funroll-loops"
- "-Wall"
- "-o"
- "FastTree"
- source
- "-lm"))
- (zero? (system* "gcc"
- "-DOPENMP"
- "-fopenmp"
- "-O3"
- "-finline-functions"
- "-funroll-loops"
- "-Wall"
- "-o"
- "FastTreeMP"
- source
- "-lm")))))
+ (invoke "gcc"
+ "-O3"
+ "-finline-functions"
+ "-funroll-loops"
+ "-Wall"
+ "-o"
+ "FastTree"
+ source
+ "-lm")
+ (invoke "gcc"
+ "-DOPENMP"
+ "-fopenmp"
+ "-O3"
+ "-finline-functions"
+ "-funroll-loops"
+ "-Wall"
+ "-o"
+ "FastTreeMP"
+ source
+ "-lm")
+ #t))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
- (let ((bin (string-append (assoc-ref outputs "out")
- "/bin")))
- (mkdir-p bin)
+ (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
(install-file "FastTree" bin)
(install-file "FastTreeMP" bin)
#t))))))