aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm144
1 files changed, 144 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f6df298db5..8ed871003a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -143,6 +143,39 @@ intervals from multiple files in widely-used genomic file formats such as BAM,
BED, GFF/GTF, VCF.")
(license license:gpl2)))
+(define-public python2-pybedtools
+ (package
+ (name "python2-pybedtools")
+ (version "0.6.9")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/p/pybedtools/pybedtools-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1ldzdxw1p4y3g2ignmggsdypvqkcwqwzhdha4rbgpih048z5p4an"))))
+ (build-system python-build-system)
+ (arguments `(#:python ,python-2)) ; no Python 3 support
+ (inputs
+ `(("python-cython" ,python2-cython)
+ ("python-matplotlib" ,python2-matplotlib)))
+ (propagated-inputs
+ `(("bedtools" ,bedtools)
+ ("samtools" ,samtools)))
+ (native-inputs
+ `(("python-pyyaml" ,python2-pyyaml)
+ ("python-nose" ,python2-nose)
+ ("python-setuptools" ,python2-setuptools)))
+ (home-page "https://pythonhosted.org/pybedtools/")
+ (synopsis "Python wrapper for BEDtools programs")
+ (description
+ "pybedtools is a Python wrapper for Aaron Quinlan's BEDtools programs,
+which are widely used for genomic interval manipulation or \"genome algebra\".
+pybedtools extends BEDTools by offering feature-level manipulations from with
+Python.")
+ (license license:gpl2+)))
+
(define-public bowtie
(package
(name "bowtie")
@@ -204,6 +237,86 @@ gapped, local, and paired-end alignment modes.")
(supported-systems '("x86_64-linux"))
(license license:gpl3+)))
+(define-public clipper
+ (package
+ (name "clipper")
+ (version "0.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/YeoLab/clipper/archive/"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1q7jpimsqln7ic44i8v2rx2haj5wvik8hc1s2syd31zcn0xk1iyq"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; remove unnecessary setup dependency
+ '(substitute* "setup.py"
+ (("setup_requires = .*") "")))))
+ (build-system python-build-system)
+ (arguments `(#:python ,python-2)) ; only Python 2 is supported
+ (inputs
+ `(("htseq" ,htseq)
+ ("python-pybedtools" ,python2-pybedtools)
+ ("python-cython" ,python2-cython)
+ ("python-scikit-learn" ,python2-scikit-learn)
+ ("python-matplotlib" ,python2-matplotlib)
+ ("python-pysam" ,python2-pysam)
+ ("python-numpy" ,python2-numpy)
+ ("python-scipy" ,python2-scipy)))
+ (native-inputs
+ `(("python-mock" ,python2-mock) ; for tests
+ ("python-pytz" ,python2-pytz) ; for tests
+ ("python-setuptools" ,python2-setuptools)))
+ (home-page "https://github.com/YeoLab/clipper")
+ (synopsis "CLIP peak enrichment recognition")
+ (description
+ "CLIPper is a tool to define peaks in CLIP-seq datasets.")
+ (license license:gpl2)))
+
+(define-public crossmap
+ (package
+ (name "crossmap")
+ (version "0.1.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/crossmap/CrossMap-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "163hi5gjgij6cndxlvbkp5jjwr0k4wbm9im6d2210278q7k9kpnp"))
+ ;; patch has been sent upstream already
+ (patches (list
+ (search-patch "crossmap-allow-system-pysam.patch")))
+ (modules '((guix build utils)))
+ ;; remove bundled copy of pysam
+ (snippet
+ '(delete-file-recursively "lib/pysam"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2
+ #:phases
+ (alist-cons-after
+ 'unpack 'set-env
+ (lambda _ (setenv "CROSSMAP_USE_SYSTEM_PYSAM" "1"))
+ %standard-phases)))
+ (inputs
+ `(("python-numpy" ,python2-numpy)
+ ("python-pysam" ,python2-pysam)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("python-cython" ,python2-cython)
+ ("python-nose" ,python2-nose)
+ ("python-setuptools" ,python2-setuptools)))
+ (home-page "http://crossmap.sourceforge.net/")
+ (synopsis "Convert genome coordinates between assemblies")
+ (description
+ "CrossMap is a program for conversion of genome coordinates or annotation
+files between different genome assemblies. It supports most commonly used
+file formats including SAM/BAM, Wiggle/BigWig, BED, GFF/GTF, VCF.")
+ (license license:gpl2+)))
+
(define-public flexbar
(package
(name "flexbar")
@@ -333,6 +446,37 @@ particular, reads spanning multiple exons.")
from high-throughput sequencing assays.")
(license license:gpl3+)))
+(define-public macs
+ (package
+ (name "macs")
+ (version "2.1.0.20140616")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/M/MACS2/MACS2-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "11lmiw6avqhwn75sn59g4lfkrr2kk20r3rgfbx9xfqb8rg9mi2n6"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2 ; only compatible with Python 2.7
+ #:tests? #f)) ; no test target
+ (inputs
+ `(("python-numpy" ,python2-numpy)))
+ (native-inputs
+ `(("python-setuptools" ,python2-setuptools)))
+ (home-page "http://github.com/taoliu/MACS/")
+ (synopsis "Model based analysis for ChIP-Seq data")
+ (description
+ "MACS is an implementation of a ChIP-Seq analysis algorithm for
+identifying transcript factor binding sites named Model-based Analysis of
+ChIP-Seq (MACS). MACS captures the influence of genome complexity to evaluate
+the significance of enriched ChIP regions and it improves the spatial
+resolution of binding sites through combining the information of both
+sequencing tag position and orientation.")
+ (license license:bsd-3)))
+
(define-public rseqc
(package
(name "rseqc")