aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/benchmark.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/benchmark.scm')
-rw-r--r--gnu/packages/benchmark.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index e97e827cea..c670a9af1c 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -135,10 +135,9 @@ is to write a job file matching the I/O load one wants to simulate.")
(replace 'build
(lambda* (#:key inputs #:allow-other-keys)
(let ((mpi-home (assoc-ref inputs "mpi")))
- (zero?
- ;; Not safe for parallel build
- (system* "make" "-C" "imb/src" "-f" "make_mpich" "SHELL=sh"
- (string-append "MPI_HOME=" mpi-home))))))
+ ;; Not safe for parallel build
+ (invoke "make" "-C" "imb/src" "-f" "make_mpich" "SHELL=sh"
+ (string-append "MPI_HOME=" mpi-home)))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))