aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm29
1 files changed, 19 insertions, 10 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 05e5295567..dec5c418a9 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -50,7 +50,6 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
- #:use-module (guix build-system perl)
#:use-module (guix build-system python)
#:use-module (guix build-system qt)
#:use-module (gnu packages)
@@ -554,6 +553,13 @@ rsnapshot uses hard links to deduplicate identical files.")
(modules '((guix build utils)))
(snippet
'(begin
+ ;; Gnulib's <stdio.h> refers to 'gets' for the purposes of
+ ;; warning against its use, but 'gets' is no longer declared
+ ;; in glibc's <stdio.h>. Remove that warning.
+ (substitute* "lib/stdio.in.h"
+ (("_GL_WARN_ON_USE \\(gets,.*")
+ "\n/* 'gets' is gone, rejoice! */\n"))
+
;; Include all the libtirpc headers necessary to get the
;; definitions of 'u_int', etc.
(substitute* '("src/block-server.c"
@@ -562,8 +568,7 @@ rsnapshot uses hard links to deduplicate identical files.")
(("#include <rpc/(.*)\\.h>" _ header)
(string-append "#include <rpc/types.h>\n"
"#include <rpc/rpc.h>\n"
- "#include <rpc/" header ".h>\n")))
- #t))))
+ "#include <rpc/" header ".h>\n")))))))
(build-system gnu-build-system)
(arguments
'(;; Link against libtirpc.
@@ -588,12 +593,16 @@ rsnapshot uses hard links to deduplicate identical files.")
(string-append (getenv "CPATH")
":" tirpc))
(setenv "CPATH" tirpc)))))
- (add-before 'check 'skip-test
+ (add-before 'check 'adjust-test
(lambda _
- ;; XXX: This test fails (1) because current GnuTLS no
- ;; longer supports OpenPGP authentication, and (2) for
- ;; some obscure reason. Better skip it.
- (setenv "XFAIL_TESTS" "utils/block-server"))))))
+ ;; This test uses a weird construct to spawn
+ ;; 'chop-block-server' in the background. Replace it
+ ;; with something that actually works.
+ (substitute* "tests/utils/block-server"
+ (("chop_fail_if ! chop-block-server")
+ "chop-block-server")
+ (("'&'")
+ "&")))))))
(native-inputs
(list guile-2.0 gperf-3.0 ;see <https://bugs.gnu.org/32382>
pkg-config rpcsvc-proto)) ;for 'rpcgen'
@@ -1324,7 +1333,7 @@ borgmatic is powered by borg.")
python-paramiko
python-peewee
python-psutil
- python-pyqt-without-qtwebkit
+ python-pyqt
python-secretstorage
;; This is included so that the qt-wrap phase picks it up.
qtsvg-5))
@@ -1351,7 +1360,7 @@ archives.")
(native-inputs (list intltool pkg-config))
(inputs (list gtk+))
(propagated-inputs (list rsync))
- (home-page "http://www.opbyte.it/grsync/")
+ (home-page "https://www.opbyte.it/grsync/")
(synopsis "GTK frontend for rsync")
(description
"Grsync is a simple graphical interface using GTK for the @command{rsync}