aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index ae4e4b20ea..986ffef08f 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -67,6 +67,7 @@
(build-system python-build-system)
(native-inputs
`(("util-linux" ,util-linux) ;setsid command, for the tests
+ ("par2cmdline" ,par2cmdline)
("python-pexpect" ,python2-pexpect)
("mock" ,python2-mock)))
(propagated-inputs
@@ -83,16 +84,18 @@
#:test-target "test"
#:phases
(modify-phases %standard-phases
- (add-before
- 'build 'patch-source ; embed gpg store name
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "duplicity/gpginterface.py"
- (("self.call = 'gpg'")
- (string-append "self.call = '" (assoc-ref inputs "gnupg") "/bin/gpg'")))))
- (add-before 'check 'check-setup
+ (add-before 'build 'patch-source
(lambda* (#:key inputs #:allow-other-keys)
- (substitute* "testing/functional/__init__.py"
+ ;; embed gpg store name
+ (substitute* "duplicity/gpginterface.py"
+ (("self.call = 'gpg'")
+ (string-append "self.call = '" (assoc-ref inputs "gnupg") "/bin/gpg'")))
+ (substitute* '("testing/functional/__init__.py"
+ "testing/overrides/bin/lftp")
(("/bin/sh") (which "sh")))
+ #t))
+ (add-before 'check 'check-setup
+ (lambda* (#:key inputs #:allow-other-keys)
(setenv "HOME" (getcwd)) ;gpg needs to write to $HOME
(setenv "TZDIR" ;some timestamp checks need TZDIR
(string-append (assoc-ref inputs "tzdata")