aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/axoloti.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/axoloti.scm')
-rw-r--r--gnu/packages/axoloti.scm28
1 files changed, 14 insertions, 14 deletions
diff --git a/gnu/packages/axoloti.scm b/gnu/packages/axoloti.scm
index 4963bb33cf..6a76ad6be7 100644
--- a/gnu/packages/axoloti.scm
+++ b/gnu/packages/axoloti.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016, 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -94,10 +94,10 @@
(add-after 'unpack 'patch-paths
(lambda* (#:key inputs #:allow-other-keys)
;; prepare ChibiOS
- (and (zero? (system* "unzip" "-o" (assoc-ref inputs "chibios")))
- (zero? (system* "mv" "ChibiOS_2.6.9" "chibios"))
- (with-directory-excursion "chibios/ext"
- (zero? (system* "unzip" "-o" "fatfs-0.9-patched.zip"))))
+ (invoke "unzip" "-o" (assoc-ref inputs "chibios"))
+ (invoke "mv" "ChibiOS_2.6.9" "chibios")
+ (with-directory-excursion "chibios/ext"
+ (invoke "unzip" "-o" "fatfs-0.9-patched.zip"))
;; Remove source of non-determinism in ChibiOS
(substitute* "chibios/os/various/shell.c"
@@ -149,7 +149,7 @@
(string-append toolchain
"/arm-none-eabi/lib")))
(with-directory-excursion "platform_linux"
- (zero? (system* "sh" "compile_firmware.sh")))))
+ (invoke "sh" "compile_firmware.sh"))))
(replace 'install
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -284,14 +284,14 @@ runtime.")
port)))
;; Build it!
- (zero? (system* "ant"
- (string-append "-Djavac.classpath=" classpath)
- "-Dbuild.runtime=true"
- "-Dbuild.time=01/01/1970 00:00:00"
- "-Djavac.source=1.7"
- "-Djavac.target=1.7"
- (string-append "-Dtag.short.version="
- ,version))))))
+ (invoke "ant"
+ (string-append "-Djavac.classpath=" classpath)
+ "-Dbuild.runtime=true"
+ "-Dbuild.time=01/01/1970 00:00:00"
+ "-Djavac.source=1.7"
+ "-Djavac.target=1.7"
+ (string-append "-Dtag.short.version="
+ ,version)))))
(replace 'install
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))