aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/aux-files/guix.vim
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/aux-files/guix.vim')
-rw-r--r--gnu/packages/aux-files/guix.vim7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/aux-files/guix.vim b/gnu/packages/aux-files/guix.vim
new file mode 100644
index 0000000000..7dc359e52b
--- /dev/null
+++ b/gnu/packages/aux-files/guix.vim
@@ -0,0 +1,7 @@
+" This appends all of the vim plugins to the end of Vim's runtimepath.
+for directory in ["/run/current-system/profile", $HOME . "/.guix-profile", $GUIX_PROFILE, $GUIX_ENVIRONMENT]
+ let vimplugins = directory . "/share/vim/vimfiles"
+ if isdirectory(vimplugins)
+ let &rtp = join([&rtp,vimplugins], ',')
+ endif
+endfor