aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm40
1 files changed, 14 insertions, 26 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 9447156e0e..0746f67b2e 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -108,6 +108,7 @@
#:use-module (gnu packages valgrind)
#:use-module (gnu packages video)
#:use-module (gnu packages vim) ;xxd
+ #:use-module (gnu packages web)
#:use-module (gnu packages webkit)
#:use-module (gnu packages wxwidgets)
#:use-module (gnu packages xiph)
@@ -1822,7 +1823,7 @@ patches that can be used with softsynths such as Timidity and WildMidi.")
(define-public guitarix
(package
(name "guitarix")
- (version "0.38.1")
+ (version "0.41.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1830,28 +1831,14 @@ patches that can be used with softsynths such as Timidity and WildMidi.")
version ".tar.xz"))
(sha256
(base32
- "0bw7xnrx062nwb1bfj9x660h7069ncmz77szcs8icpqxrvhs7z80"))))
+ "0qsfbyrrpb3bbdyq68k28mjql7kglxh8nqcw9jvja28x6x9ik5a0"))))
(build-system waf-build-system)
(arguments
`(#:tests? #f ; no "check" target
- #:python ,python-2
#:configure-flags
(list
;; Add the output lib directory to the RUNPATH.
- (string-append "--ldflags=-Wl,-rpath=" %output "/lib"))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-boost-includes
- (lambda _
- (substitute* "src/headers/gx_internal_plugins.h"
- (("namespace gx_jack" m)
- (string-append "#include <boost/noncopyable.hpp>\n" m)))
- (substitute* '("src/headers/gx_system.h"
- "src/headers/gx_parameter.h"
- "src/headers/gx_json.h")
- (("namespace gx_system" m)
- (string-append "#include <boost/noncopyable.hpp>\n" m)))
- #t)))))
+ (string-append "--ldflags=-Wl,-rpath=" %output "/lib"))))
(inputs
`(("libsndfile" ,libsndfile)
("boost" ,boost)
@@ -1862,8 +1849,8 @@ patches that can be used with softsynths such as Timidity and WildMidi.")
("lilv" ,lilv)
("ladspa" ,ladspa)
("jack" ,jack-1)
- ("gtkmm" ,gtkmm-2)
- ("gtk+" ,gtk+-2)
+ ("gtkmm" ,gtkmm)
+ ("gtk+" ,gtk+)
("fftwf" ,fftwf)
("lrdf" ,lrdf)
("zita-resampler" ,zita-resampler)
@@ -1873,7 +1860,8 @@ patches that can be used with softsynths such as Timidity and WildMidi.")
("faust" ,faust)
("intltool" ,intltool)
("gettext" ,gettext-minimal)
- ("pkg-config" ,pkg-config)))
+ ("pkg-config" ,pkg-config)
+ ("sassc" ,sassc)))
(native-search-paths
(list (search-path-specification
(variable "LV2_PATH")
@@ -4025,14 +4013,14 @@ on the ALSA software PCM plugin.")
(define-public snd
(package
(name "snd")
- (version "20.6")
+ (version "20.7")
(source (origin
(method url-fetch)
(uri (string-append "ftp://ccrma-ftp.stanford.edu/pub/Lisp/"
"snd-" version ".tar.gz"))
(sha256
(base32
- "1h4dsq5xcvwjbnayhn719cln0lg199w3xm59sl9d2jz8bq78gqgj"))))
+ "1kd422krz8ln4m8g3p14wfplcq8lgpzly9297rpbvyc94dc6sdwj"))))
(build-system glib-or-gtk-build-system)
(arguments
`(#:tests? #f ; no tests
@@ -4479,7 +4467,7 @@ supports both of ID3v1/v2 and APEv2 tags.")
(define-public redkite
(package
(name "redkite")
- (version "0.8.1")
+ (version "1.0.3")
(source
(origin
(method git-fetch)
@@ -4488,7 +4476,7 @@ supports both of ID3v1/v2 and APEv2 tags.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "17kv2jc4jvn3sdicz3sf8dnf25wbvv7ijzkr0mm0sbrrjz6vrwz0"))))
+ (base32 "1m2db7c791fi33snkjwnvlxapmf879g5r8azlkx7sr6vp2s0jq2k"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f)) ;no tests included
@@ -4652,7 +4640,7 @@ libsamplerate for reading and resampling audio files, based on Robin Gareus'
(define-public lv2lint
(package
(name "lv2lint")
- (version "0.4.0")
+ (version "0.8.0")
(source
(origin
(method git-fetch)
@@ -4662,7 +4650,7 @@ libsamplerate for reading and resampling audio files, based on Robin Gareus'
(file-name (git-file-name name version))
(sha256
(base32
- "1pspwqpzl2dw1hd9ra9yr53arqbbqjn7d7j0f7p9g3iqa76vblpi"))))
+ "1jrka0hsn4n1clri7zfkcl3c2vi52144lkpjm81l51ff8rqy8ks1"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags