aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 3d12a87f8a..98ef7b3a7e 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -816,6 +816,31 @@ Astronomical Union (IAU). All C routines are wrapped as Numpy universal
functions, so that they can be called with scalar or array inputs.")
(license license:bsd-3)))
+(define-public python-sep
+ (package
+ (name "python-sep")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sep" version))
+ (sha256
+ (base32 "0wxdqn92q1grv8k7xi7h88ac6wnznw4xh5bdlz1vz6za2dgsyj4m"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("cython" ,python-cython)
+ ("pytest" ,python-pytest)))
+ (inputs
+ `(("numpy" ,python-numpy)))
+ (home-page "https://github.com/kbarbary/sep")
+ (synopsis "Astronomical source extraction and photometry library")
+ (description
+ "SEP makes the core algorithms of Source Extractor available as a library
+of stand-alone functions and classes.")
+ (license (list license:bsd-3
+ license:expat
+ license:lgpl3+))))
+
(define-public python-skyfield
(package
(name "python-skyfield")