aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm18
1 files changed, 1 insertions, 17 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 8e3327eafe..b859da0e7e 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2015, 2016 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2013, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2015, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
@@ -577,22 +577,6 @@ cosine/ sine transforms or DCT/DST).")
(string-append (package-description fftw)
" Single-precision version."))))
-;; FIXME: These packages are used temporarily by packages like Ardour until
-;; "--enable-flags" is added to the fftw and fftwf packages.
-(define-public fftw-with-threads
- (package (inherit fftw)
- (arguments
- (substitute-keyword-arguments (package-arguments fftw)
- ((#:configure-flags flags)
- `(cons "--enable-threads" ,flags))))))
-
-(define-public fftwf-with-threads
- (package (inherit fftwf)
- (arguments
- (substitute-keyword-arguments (package-arguments fftwf)
- ((#:configure-flags flags)
- `(cons "--enable-threads" ,flags))))))
-
(define-public fftw-openmpi
(package (inherit fftw)
(name "fftw-openmpi")