aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm65
1 files changed, 35 insertions, 30 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index aedfdb58e7..d92e963af4 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2014, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017, 2020 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017, 2019 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
@@ -13,6 +13,7 @@
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021 Lars-Dominik Braun <ldb@leibniz-psychology.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -44,7 +45,6 @@
#:use-module (gnu packages graphviz)
#:use-module (gnu packages image)
#:use-module (gnu packages java)
- #:use-module (gnu packages llvm)
#:use-module (gnu packages maths)
#:use-module (gnu packages mpi)
#:use-module (gnu packages multiprecision)
@@ -64,6 +64,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system cmake)
#:use-module (guix build-system python)
+ #:use-module (guix build-system r)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix hg-download)
@@ -307,24 +308,10 @@ GP2C, the GP to C compiler, translates GP scripts to PARI programs.")
(license license:gpl2)
(home-page "https://pari.math.u-bordeaux.fr/")))
-(define fplll-4-cmh
- (package
- (inherit fplll)
- (name "fplll")
- (version "4.0.4")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "http://perso.ens-lyon.fr/damien.stehle/fplll/libfplll-"
- version ".tar.gz"))
- (sha256
- (base32 "1cbiby7ykis4z84swclpysrljmqhfcllpkcbll1m08rzskgb1a6b"))))))
-
(define-public cmh
(package
(name "cmh")
- (version "1.0")
+ (version "1.1.0")
(source (origin
(method url-fetch)
;; Git repo at <https://gitlab.inria.fr/cmh/cmh>.
@@ -332,14 +319,14 @@ GP2C, the GP to C compiler, translates GP scripts to PARI programs.")
version ".tar.gz"))
(sha256
(base32
- "1a28xr9bs0igms0ik99x0w8lnb0jyfcmvyi26pbyh9ggcdivd33p"))))
+ "1ws2yhzxmm2l5xqqqcjcimmg40f9qq5l9i6d4i5434an9v9s8531"))))
(build-system gnu-build-system)
(inputs
`(("gmp" ,gmp)
("mpfr" ,mpfr)
("mpc" ,mpc)
("mpfrcx" ,mpfrcx)
- ("fplll" ,fplll-4-cmh)
+ ("fplll" ,fplll)
("pari-gp" ,pari-gp)))
(synopsis "Igusa class polynomial computations")
(description
@@ -354,7 +341,7 @@ precision.")
(define-public giac
(package
(name "giac")
- (version "1.6.0-47")
+ (version "1.7.0-1")
(source
(origin
(method url-fetch)
@@ -366,7 +353,7 @@ precision.")
"~parisse/debian/dists/stable/main/source/"
"giac_" version ".tar.gz"))
(sha256
- (base32 "15sgsr8l6njp5spagbqclqkdy3x7ra23wi6wvpc8vzlbivy3v43k"))))
+ (base32 "0s926aza2larfz02hrhdlpxn77yjlrhjg844b3fhwz11yj942p9q"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((ice-9 ftw)
@@ -571,19 +558,19 @@ arithmetic). It supports integers, rationals, modular integers,
real and complex ball arithmetic, polynomials and matrices over all
these types and other mathematical functions.")
(license license:expat)
- (home-page "http://fredrikj.net/python-flint/")))
+ (home-page "https://fredrikj.net/python-flint/")))
(define-public ntl
(package
(name "ntl")
- (version "11.4.3")
+ (version "11.4.4")
(source (origin
(method url-fetch)
(uri (string-append "https://shoup.net/ntl/ntl-"
version ".tar.gz"))
(sha256
(base32
- "1lisp3064rch3jaa2wrhy1s9kll7i3ka3d0y6lj6l3l4ckfcrhdp"))
+ "1nr1h27j2gdz6badzz9lk2pknxhdijqdxqhd3haryh0sw616wzwx"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -665,7 +652,7 @@ geometry and singularity theory.")
;; libraries with which it links are licensed under lgpl3+, so the
;; combined work becomes gpl3. See COPYING in the source code.
(license license:gpl3)
- (home-page "http://www.singular.uni-kl.de/index.php")))
+ (home-page "https://www.singular.uni-kl.de/index.php")))
(define-public gmp-ecm
(package
@@ -807,7 +794,7 @@ cosine/ sine transforms or DCT/DST).")
(license license:gpl2+)))
(define-public fftwf
- (package (inherit fftw)
+ (package/inherit fftw
(name "fftwf")
(arguments
(substitute-keyword-arguments (package-arguments fftw)
@@ -825,7 +812,7 @@ cosine/ sine transforms or DCT/DST).")
" Single-precision version."))))
(define-public fftw-openmpi
- (package (inherit fftw)
+ (package/inherit fftw
(name "fftw-openmpi")
(inputs
`(("openmpi" ,openmpi)
@@ -985,11 +972,8 @@ algorithms from the FORTRAN library MINPACK.")
"-DWITH_MPFR=on"
"-DWITH_MPC=on"
"-DINTEGER_CLASS=flint"
- "-DWITH_LLVM=on"
"-DWITH_SYMENGINE_THREAD_SAFE=on"
"-DBUILD_SHARED_LIBS=on"))) ;also build libsymengine
- (native-inputs
- `(("llvm" ,llvm)))
(inputs
`(("flint" ,flint)
("gmp" ,gmp)
@@ -1602,3 +1586,24 @@ general purpose; they require that p satisfy some preconditions based on
the dimension of the input matrix (usually p should be prime and should be
no more than about 20 bits long).")
(license license:bsd-3)))
+
+(define-public r-dtt
+ (package
+ (name "r-dtt")
+ (version "0.1-2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "dtt" version))
+ (sha256
+ (base32
+ "0n8gj5iylfagdbaqirpykb01a9difsy4zl6qq55f0ghvazxqdvmn"))))
+ (properties `((upstream-name . "dtt")))
+ (build-system r-build-system)
+ (home-page "http://www.r-project.org")
+ (synopsis "Discrete Trigonometric Transforms")
+ (description
+ "This package provides functions for 1D and 2D Discrete Cosine Transform
+(@dfn{DCT}), Discrete Sine Transform (@dfn{DST}) and Discrete Hartley Transform
+(@dfn{DHT}).")
+ (license license:gpl2+)))