aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm22
1 files changed, 18 insertions, 4 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 17d726b7ac..d2001d4e2c 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1699,15 +1699,29 @@ throughput (in the same interval).")
(base32
"04q2cn8c83f6z6wn1scla1ilrpi5ssjc64987hvmwfvwvb82bvkp"))))
(build-system python-build-system)
- (inputs
+ (arguments
+ '(#:tests? #f))
+ ;; FIXME: 10 test failures. Some require newer pytest (> 2.9.2).
+ ;; Others need more work. Un-comment the below to run the tests.
+ ;; #:phases
+ ;; (modify-phases %standard-phases
+ ;; (replace 'check
+ ;; (lambda _
+ ;; ;; Some tests need write access to $HOME.
+ ;; (setenv "HOME" "/tmp")
+ ;; (zero? (system* "py.test" "-v")))))))
+ (propagated-inputs
`(("python-colorama" ,python-colorama)
("python-decorator" ,python-decorator)
("python-psutil" ,python-psutil)
("python-six" ,python-six)))
(native-inputs
- ;; Requires setuptools >= 17.1 due to some features used, while our
- ;; python currently only includes 12.0. TODO: Remove this input.
- `(("python-setuptools" ,python-setuptools)))
+ `(("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-mock" ,python-pytest-mock)
+ ;; Requires setuptools >= 17.1 due to some features used, while our
+ ;; python currently only includes 12.0. TODO: Remove this input.
+ ("python-setuptools" ,python-setuptools)))
(home-page "https://github.com/nvbn/thefuck")
(synopsis "Correct mistyped console command")
(description