aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm135
1 files changed, 69 insertions, 66 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 529a477ed0..e9e949bf14 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -592,7 +592,7 @@ graphs and can export its output to different formats.")
(define-public facter
(package
(name "facter")
- (version "4.0.52")
+ (version "4.4.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -601,63 +601,61 @@ graphs and can export its output to different formats.")
(file-name (git-file-name name version))
(sha256
(base32
- "05j4q87sak1f1isj7ngzr59h3j3xskfwjjwfv0xd7lhwcaxg3a3c"))))
+ "080v0ml2svw2vbzfa659v8718pmhh2kav0l0q1jjvc6mm8sgnmmn"))))
(build-system ruby-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'delete-facter-ng-gemspec
- (lambda _
- ;; XXX: ruby-build-system incorrectly finds
- ;; facter-ng.gemspec from this directory and tries to
- ;; build that instead of the proper facter.gemspec.
- ;; Just delete it as a workaround, as it appears to
- ;; only exist for backwards-compatibility after the
- ;; facter-ng->facter rename.
- (delete-file "agent/facter-ng.gemspec")
- #t))
- (add-after 'unpack 'embed-absolute-references
- ;; Refer to absolute executable file names to avoid propagation.
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* (find-files "lib/facter/resolvers" "\\.rb$")
- (("execute\\('(which |)([^ ']+)" _ _ name)
- (string-append "execute('" (or (which name)
- name))))
- #t))
- (delete 'check)
- (add-after 'wrap 'check
- (lambda* (#:key tests? outputs #:allow-other-keys)
- ;; XXX: The test suite wants to run Bundler and
- ;; complains that the gemspec is invalid. For now
- ;; just make sure that we can run the wrapped
- ;; executable directly.
- (if tests?
- (invoke (string-append (assoc-ref outputs "out")
- "/bin/facter")
- ;; Many facts depend on /sys, /etc/os-release,
- ;; etc, so we only run a small sample.
- "facterversion" "architecture"
- "kernel" "kernelversion")
- (format #t "tests disabled~%"))
- #t)))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'delete-facter-ng-gemspec
+ (lambda _
+ ;; XXX: ruby-build-system incorrectly finds
+ ;; facter-ng.gemspec from this directory and tries to
+ ;; build that instead of the proper facter.gemspec.
+ ;; Just delete it as a workaround, as it appears to
+ ;; only exist for backwards-compatibility after the
+ ;; facter-ng->facter rename.
+ (delete-file "agent/facter-ng.gemspec")))
+ (add-after 'unpack 'embed-absolute-references
+ ;; Refer to absolute executable file names to avoid propagation.
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* (find-files "lib/facter/resolvers" "\\.rb$")
+ (("execute\\('(which |)([^ ']+)" _ _ name)
+ (string-append "execute('" (or (which name)
+ name))))))
+ (delete 'check)
+ (add-after 'wrap 'check
+ (lambda* (#:key tests? outputs #:allow-other-keys)
+ ;; XXX: The test suite wants to run Bundler and
+ ;; complains that the gemspec is invalid. For now
+ ;; just make sure that we can run the wrapped
+ ;; executable directly.
+ (if tests?
+ (invoke (string-append (assoc-ref outputs "out")
+ "/bin/facter")
+ ;; Many facts depend on /sys, /etc/os-release,
+ ;; etc, so we only run a small sample.
+ "facterversion" "architecture"
+ "kernel" "kernelversion")
+ (format #t "tests disabled~%")))))))
(inputs
- `(("ruby-hocon" ,ruby-hocon)
- ("ruby-sys-filesystem" ,ruby-sys-filesystem)
- ("ruby-thor" ,ruby-thor)
-
- ;; For ‘embed-absolute-references’.
- ("dmidecode" ,dmidecode)
- ("inetutils" ,inetutils) ; for ‘hostname’
- ("iproute" ,iproute)
- ("pciutils" ,pciutils)
- ("util-linux" ,util-linux)))
+ (list ruby-hocon
+ ruby-sys-filesystem
+ ruby-thor
+
+ ;; For ‘embed-absolute-references’.
+ dmidecode
+ inetutils ; for ‘hostname’
+ iproute
+ pciutils
+ util-linux))
(synopsis "Collect and display system facts")
(description
"Facter is a tool that gathers basic facts about nodes (systems) such
as hardware details, network settings, OS type and version, and more. These
facts can be collected on the command line with the @command{facter} command
or via the @code{facter} Ruby library.")
- (home-page "https://github.com/puppetlabs/facter-ng")
+ (home-page "https://github.com/puppetlabs/facter")
(license license:expat)))
(define-public ttyload
@@ -1661,14 +1659,14 @@ network statistics collection, security monitoring, network debugging, etc.")
(define-public tcpdump
(package
(name "tcpdump")
- (version "4.99.1")
+ (version "4.99.4")
(source (origin
(method url-fetch)
(uri (string-append "https://www.tcpdump.org/release/tcpdump-"
version ".tar.gz"))
(sha256
(base32
- "1ghfs5gifzrk3813zf9zalfbjs70wg6llz6q31k180r7zf2nkcvr"))))
+ "1slzwjk5f8sygwxqci4vkbas0qqcgs5a0w3f8br6p7gjn8dj6ch2"))))
(build-system gnu-build-system)
(inputs (list libpcap openssl))
(native-inputs (list perl)) ; for tests
@@ -2733,7 +2731,7 @@ various ways that may be running with too much privilege.")
(define-public smartmontools
(package
(name "smartmontools")
- (version "7.2")
+ (version "7.3")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2741,7 +2739,7 @@ various ways that may be running with too much privilege.")
version "/smartmontools-" version ".tar.gz"))
(sha256
(base32
- "1mlc25sd5rgj5xmzcllci47inmfdw7cp185fday6hc9rwqkqmnaw"))))
+ "0ax2wf5j8k2fbm85s0rbj9sajn5q3j2a2k22wyqcyn0cin0ghi55"))))
(build-system gnu-build-system)
(arguments
(list #:make-flags
@@ -3543,24 +3541,27 @@ a new command using the matched rule, and runs it.")
(define-public di
(package
(name "di")
- (version "4.51")
+ (version "4.52")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://sourceforge/diskinfo-di/di-" version ".tar.gz"))
+ (uri (string-append "mirror://sourceforge/diskinfo-di/"
+ "di-" version ".tar.gz"))
(sha256
- (base32 "1fv12j9b9sw6p38lcbzcw87zl5qp1aa7a4a4jn3449zz9af15ckr"))))
+ (base32 "07vsnn1gxm3r7dchbrq63iazd64gza2ac7b2m1039708rf5flxdp"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; obscure test failures
- #:phases
- (modify-phases %standard-phases
- (delete 'configure) ; no configure script
- (add-before 'build 'setup-environment
- (lambda* (#:key outputs #:allow-other-keys)
- (setenv "CC" ,(cc-for-target))
- (setenv "prefix" (assoc-ref outputs "out")))))
- #:make-flags (list "--environment-overrides")))
+ (list
+ #:tests? #f ; obscure test failures
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure) ; no configure script
+ (add-before 'build 'override-environment
+ (lambda _
+ (setenv "CC" #$(cc-for-target))
+ (setenv "prefix" #$output))))
+ #:make-flags
+ #~(list "--environment-overrides")))
(home-page "https://gentoo.com/di/")
(synopsis "Advanced df like disk information utility")
(description
@@ -3903,7 +3904,9 @@ buffers.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0d6jsj77qddccv0vfmqmbw3k2prvxzvmgc8zdi83gdi3wpp5i7zd"))))
+ (base32 "0d6jsj77qddccv0vfmqmbw3k2prvxzvmgc8zdi83gdi3wpp5i7zd"))
+ (patches
+ (search-patches "igt-gpu-tools-Use-libproc2.patch"))))
(build-system meson-build-system)
(arguments
`(#:tests? #f ; many of the tests try to load kernel modules