aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm50
1 files changed, 26 insertions, 24 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index f0581bbea5..371fcc7ec3 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -30,6 +30,7 @@
;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2904,34 +2905,35 @@ tool for remote execution and deployment.")
(license license:bsd-2)))
(define-public neofetch
- (package
- (name "neofetch")
- (version "6.1.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/dylanaraps/neofetch")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "022xzn9jk18k2f4b6011d8jk5nbl84i3mw3inlz4q52p2hvk8fch"))))
- (build-system gnu-build-system)
- (arguments
- `(#:tests? #f ; there are no tests
- #:make-flags
- (list (string-append "PREFIX=" %output))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)))) ; no configure script
- (home-page "https://github.com/dylanaraps/neofetch")
- (synopsis "System information script")
- (description "Neofetch is a command-line system information tool written in
+ (let ((commit "501d6b7594296d9eac8943140f8581daf555873d"))
+ (package
+ (name "neofetch")
+ (version (git-version "6.1.0" "1" commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dylanaraps/neofetch")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1h5md9jimyc6z4d7w66j27hn8qghzyxgpkh5h9dclzxpp5cs8whb"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; there are no tests
+ #:make-flags
+ (list (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)))) ; no configure script
+ (home-page "https://github.com/dylanaraps/neofetch")
+ (synopsis "System information script")
+ (description "Neofetch is a command-line system information tool written in
Bash. Neofetch displays information about your system next to an image, your OS
logo, or any ASCII file of your choice. The main purpose of Neofetch is to be
used in screenshots to show other users what operating system or distribution
you are running, what theme or icon set you are using, etc.")
- (license license:expat)))
+ (license license:expat))))
(define-public screenfetch
(package