aboutsummaryrefslogtreecommitdiff
path: root/etc
diff options
context:
space:
mode:
Diffstat (limited to 'etc')
-rw-r--r--etc/teams.scm.in14
1 files changed, 13 insertions, 1 deletions
diff --git a/etc/teams.scm.in b/etc/teams.scm.in
index 9c7ae31275..17d0fe11ba 100644
--- a/etc/teams.scm.in
+++ b/etc/teams.scm.in
@@ -159,7 +159,19 @@ importer, and the ocaml-build-system."
#:name "Java and Maven team"
#:description
"The JDK and JRE, the Maven build system, Java packages, the ant-build-system,
-and the maven-build-system."))
+and the maven-build-system."
+ #:scope
+ (list ;; Match java.scm and java-*.scm.
+ (make-regexp "^gnu/packages/java(-.+|)\\.scm$")
+ ;; Match maven.scm and maven-*.scm
+ (make-regexp "^gnu/packages/maven(-.+|)\\.scm$")
+ "guix/build/ant-build-system.scm"
+ "guix/build/java-utils.scm"
+ "guix/build/maven-build-system.scm"
+ ;; The maven directory
+ (make-regexp "^guix/build/maven/")
+ "guix/build-system/ant.scm"
+ "guix/build-system/maven.scm")))
(define-team science
(team 'science