aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index aed8287bfd..821e746fe8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -58,6 +58,23 @@ else
AC_MSG_WARN([Please use `--with-nixpkgs'.])
fi
+AC_ARG_WITH([libgcrypt-prefix],
+ [AS_HELP_STRING([--with-libgcrypt-prefix=DIR], [search for GNU libgcrypt in DIR])],
+ [case "$withval" in
+ yes|no)
+ LIBGCRYPT="libgcrypt"
+ ;;
+ *)
+ LIBGCRYPT="$withval/lib/libgcrypt"
+ ;;
+ esac],
+ [LIBGCRYPT="libgcrypt"])
+
+dnl Library name suitable for `dynamic-link'.
+AC_MSG_CHECKING([for libgcrypt shared library name])
+AC_MSG_RESULT([$LIBGCRYPT])
+AC_SUBST([LIBGCRYPT])
+
AC_CONFIG_FILES([Makefile
po/Makefile.in
guix-build])