aboutsummaryrefslogtreecommitdiff
path: root/build-aux/hydra
diff options
context:
space:
mode:
Diffstat (limited to 'build-aux/hydra')
-rw-r--r--build-aux/hydra/gnu-system.scm33
-rw-r--r--build-aux/hydra/guix.scm33
2 files changed, 36 insertions, 30 deletions
diff --git a/build-aux/hydra/gnu-system.scm b/build-aux/hydra/gnu-system.scm
index cfef7dc425..8d9b43c0b0 100644
--- a/build-aux/hydra/gnu-system.scm
+++ b/build-aux/hydra/gnu-system.scm
@@ -54,6 +54,7 @@
(gnu packages multiprecision)
(gnu packages make-bootstrap)
(gnu packages commencement)
+ (gnu packages package-management)
(gnu system)
(gnu system vm)
(gnu system install)
@@ -158,9 +159,33 @@ system.")
(set-guile-for-build (default-guile))
(system-disk-image installation-os
#:disk-image-size
- (* 800 MiB))))))
+ (* 860 MiB))))))
'()))
+(define (tarball-jobs store system)
+ "Return Hydra jobs to build the self-contained Guix binary tarball."
+ (define (->alist drv)
+ `((derivation . ,(derivation-file-name drv))
+ (description . "Stand-alone binary Guix tarball")
+ (long-description . "This is a tarball containing binaries of Guix and
+all its dependencies, and ready to be installed on non-GuixSD distributions.")
+ (license . ,gpl3+)
+ (home-page . ,%guix-home-page-url)
+ (maintainers . ("bug-guix@gnu.org"))))
+
+ (define (->job name drv)
+ (let ((name (symbol-append name (string->symbol ".")
+ (string->symbol system))))
+ `(,name . ,(cut ->alist drv))))
+
+ ;; XXX: Add a job for the stable Guix?
+ (list (->job 'binary-tarball
+ (run-with-store store
+ (mbegin %store-monad
+ (set-guile-for-build (default-guile))
+ (self-contained-tarball))
+ #:system system))))
+
(define job-name
;; Return the name of a package's job.
(compose string->symbol package-full-name))
@@ -179,8 +204,7 @@ system.")
valid."
(cond ((member package base-packages)
#f)
- ((member system
- (package-transitive-supported-systems package))
+ ((supported-package? package system)
(package-job store (job-name package) package system))
(else
#f)))))
@@ -234,6 +258,7 @@ valid."
(cons job result)
result)))
(append (qemu-jobs store system)
+ (tarball-jobs store system)
(cross-jobs system))))
((core)
;; Build core packages only.
@@ -244,4 +269,4 @@ valid."
(cross-jobs system)))
(else
(error "unknown subset" subset))))
- %supported-systems))
+ %hydra-supported-systems))
diff --git a/build-aux/hydra/guix.scm b/build-aux/hydra/guix.scm
index 3996a0b422..1035f81b4a 100644
--- a/build-aux/hydra/guix.scm
+++ b/build-aux/hydra/guix.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -68,25 +68,10 @@
(home-page . ,(package-home-page package))
(maintainers . ("bug-guix@gnu.org"))))
-(define (tarball-package checkout nix-checkout)
+(define (tarball-package checkout)
"Return a package that does `make distcheck' from CHECKOUT, a directory
containing a Git checkout of Guix."
- (let ((dist (dist-package guix checkout)))
- (package (inherit dist)
- (location (source-properties->location (current-source-location)))
- (arguments (substitute-keyword-arguments (package-arguments dist)
- ((#:phases p)
- `(alist-cons-before
- 'autoreconf 'set-nix-submodule
- (lambda _
- ;; Tell Git to use the Nix checkout that Hydra gave us.
- (zero?
- (system* "git" "config" "submodule.nix-upstream.url"
- ,nix-checkout)))
- ,p))))
- (native-inputs `(("git" ,git)
- ("graphviz" ,graphviz)
- ,@(package-native-inputs dist))))))
+ (dist-package guix checkout))
(define (hydra-jobs store arguments)
"Return Hydra jobs."
@@ -104,13 +89,9 @@ containing a Git checkout of Guix."
(define guix-checkout
(assq-ref arguments 'guix))
- (define nix-checkout
- (assq-ref arguments 'nix))
-
- (format (current-error-port) "using checkout ~s (Nix: ~s)~%"
- guix-checkout nix-checkout)
- (let ((guix (assq-ref guix-checkout 'file-name))
- (nix (assq-ref nix-checkout 'file-name)))
+ (let ((guix (assq-ref guix-checkout 'file-name)))
+ (format (current-error-port) "using checkout ~s (~s)~%"
+ guix-checkout guix)
`((tarball . ,(cute package->alist store
- (tarball-package guix nix)
+ (tarball-package guix)
(%current-system))))))