aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 25b3eb3378..98008c528d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1241,7 +1241,12 @@ COMMIT_MSG_MAGIC = VGhpcyBpcyB0aGUgY29tbWl0LW1zZyBob29rIG9mIEd1aXg=
cp etc/git/commit-msg $@; \
fi
+# The etc/git/ config files are not distributed and have no use when building
+# from a tarball. Do not add dependencies on these to *_DATA when building
+# from a tarball, as that breaks the build.
+if in_git_p
nodist_noinst_DATA = .git/hooks/pre-push .git/config .git/hooks/commit-msg
+endif
# Downloading up-to-date PO files.