aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 7f2281cfa4..908eaf6ec0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -495,7 +495,10 @@ gen-AUTHORS:
# Make sure we're not shipping a file that embeds a local /gnu/store file name.
assert-no-store-file-names:
$(AM_V_at)if grep -r --exclude=*.texi --exclude=*.info \
- "$(storedir)/[a-z0-9]{32}-" $(distdir) ; \
+ --exclude=*.info-[0-9] --exclude=*.dot \
+ --exclude=*.eps --exclude-dir=bootstrap \
+ --exclude=guix-prettify.el \
+ -E "$(storedir)/[a-z0-9]{32}-" $(distdir) ; \
then \
echo "error: store file names embedded in the distribution" >&2 ; \
exit 1 ; \