aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index caa204e60a..bc95fd2aa4 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -3946,3 +3946,30 @@ if no cluster is present or wished. The package is also designed as connector
to the cluster management tool @code{sfCluster}, but can also used without
it.")
(license license:gpl2+)))
+
+(define-public r-codedepends
+ (package
+ (name "r-codedepends")
+ (version "0.5-3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "CodeDepends" version))
+ (sha256
+ (base32
+ "03p82s0abca2jimzqvxdzykfzca7c7fhm5xsjxybcksr4gggr5sc"))))
+ (properties `((upstream-name . "CodeDepends")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-codetools" ,r-codetools)
+ ("r-xml" ,r-xml)))
+ (home-page "http://cran.r-project.org/web/packages/CodeDepends")
+ (synopsis "Analysis of R code for reproducible research and code comprehension")
+ (description
+ "This package provides tools for analyzing R expressions or blocks of
+code and determining the dependencies between them. It focuses on R scripts,
+but can be used on the bodies of functions. There are many facilities
+including the ability to summarize or get a high-level view of code,
+determining dependencies between variables, code improvement suggestions.")
+ ;; Any version of the GPL
+ (license (list license:gpl2+ license:gpl3+))))