aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/qt.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 115b796af6..16ce1fc3c4 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -5207,6 +5207,16 @@ services using the XML based SOAP protocol and without the need for a dedicated
web server.")
(license (list license:gpl2 license:gpl3))))
+(define-public kdsoap-qt6
+ (package
+ (inherit kdsoap)
+ (name "kdsoap-qt6")
+ (arguments (substitute-keyword-arguments (package-arguments kdsoap)
+ ((#:configure-flags flags #~(list))
+ #~(cons "-DKDSoap_QT6=true" #$flags))))
+ (inputs (modify-inputs (package-inputs kdsoap)
+ (replace "qtbase" qtbase)))))
+
(define-public libaccounts-qt
(package
(name "libaccounts-qt")