aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ab00edc877..a81c4f8d02 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7352,7 +7352,7 @@ formatting information, rather than the current locale name.")
(define-public go-github-com-prometheus-procfs
(package
(name "go-github-com-prometheus-procfs")
- (version "0.0.4")
+ (version "0.15.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -7361,14 +7361,17 @@ formatting information, rather than the current locale name.")
(file-name (git-file-name name version))
(sha256
(base32
- "1z5jq5rjala0a0di4nwk1rai0z9f73qwqj6mgcbpjbg2qknlb544"))))
+ "116ns8k1yjdj9a2vq5czlpmafrhy0yw5y0bcm1qqbqnn57agg68m"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/prometheus/procfs"
;; The tests require Go modules, which are not yet supported in Guix's
;; Go build system.
#:tests? #f))
- (propagated-inputs (list go-golang-org-x-sync))
+ (propagated-inputs
+ (list go-github-com-google-go-cmp
+ go-golang-org-x-sync
+ go-golang-org-x-sys))
(synopsis "Go library for reading @file{/proc}")
(description "The @code{procfs} Go package provides functions to retrieve
system, kernel, and process metrics from the @file{/proc} pseudo file system.")