aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ruby.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index f2922ecfc7..5aa31b1bd3 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4155,6 +4155,43 @@ rogue test/unit/autorun requires.")
(home-page "https://github.com/cucumber/multi_test")
(license license:expat)))
+(define-public ruby-mustache
+ (package
+ (name "ruby-mustache")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "mustache" version))
+ (sha256
+ (base32
+ "1698xpwxmfvj39ii5vv8a4aka54p3fpk5i4rf8z9lfxrh4948rbk"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-unnecessary-dependencies
+ (lambda _
+ (substitute* "test/helper.rb"
+ (("require 'simplecov'") "")
+ (("SimpleCov\\.start") "[].each"))
+ #t)))))
+ (synopsis "Mustache is a framework-agnostic way to render logic-free views")
+ (description
+ "Inspired by ctemplate, Mustache is a framework-agnostic way to render
+logic-free views.
+
+As ctemplates says, \"It emphasizes separating logic from presentation:
+it is impossible to embed application logic in this template
+language.
+
+Think of Mustache as a replacement for your views. Instead of views
+consisting of ERB or HAML with random helpers and arbitrary logic,
+your views are broken into two parts: a Ruby class and an HTML
+template.")
+ (home-page "https://github.com/mustache/mustache")
+ (license license:expat)))
+
(define-public ruby-arel
(package
(name "ruby-arel")