aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ruby.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 50eb29204f..d1d1db6860 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6118,3 +6118,37 @@ using a strict syntax definition and supporting several common extensions.
"Fails your build if code quality thresholds are not met")
(home-page "http://github.com/square/cane")
(license license:asl2.0)))
+
+(define-public ruby-parallel
+ (package
+ (name "ruby-parallel")
+ (version "1.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ ;; fetch from github as rubygem does not contain tests
+ (uri (string-append "https://github.com/grosser/parallel/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0py2zv58ar26v2inxbwq83p9ay62q74gh28iw6mvcfbyiiqby8im"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:test-target "rspec-rerun:spec"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'patch-gemspec
+ (lambda _
+ (substitute* "parallel.gemspec"
+ (("git ls-files") "find"))
+ #t)))))
+ (native-inputs
+ `(("ruby-rspec" ,ruby-rspec)
+ ("bundler" ,bundler)
+ ("ruby-i18n" ,ruby-i18n)))
+ (synopsis "Run Ruby code in parallel processes")
+ (description
+ "Run any kind of code in parallel processes")
+ (home-page "https://github.com/grosser/parallel")
+ (license license:expat)))