aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ruby.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 1842907f92..5b3649c165 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6462,3 +6462,27 @@ than closing tags. It was originally envisioned as a plugin for Ruby on Rails,
but it can function as a stand-alone templating engine.")
(home-page "http://haml.info/")
(license license:expat)))
+
+;; haml 3 cannot currently be packaged because action_pack, action_controller
+;; and action_view are required at test time.
+(define-public ruby-haml-3
+ (package
+ (name "ruby-haml")
+ (version "3.1.8")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "haml" version))
+ (sha256
+ (base32
+ "05qnmrcjp85bgjwgmb0yhi7jyb7vd9jdqgxhzc7mmz0ch58rvxj4"))))
+ (build-system ruby-build-system)
+ ; (arguments
+ ; `(#:tests? #f))
+ (synopsis "Haml (HTML Abstraction Markup Language) library.")
+ (description
+ "Haml (HTML Abstraction Markup Language) is a layer on top of HTML or XML
+that is designed to express the structure of documents using indentation rather
+than closing tags. It was originally envisioned as a plugin for Ruby on Rails,
+but it can function as a stand-alone templating engine.")
+ (home-page "http://haml.info/")
+ (license license:expat)))