aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/check.scm22
-rw-r--r--gnu/packages/xdisorg.scm2
2 files changed, 5 insertions, 19 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 7e713c6e86..4f24335d6b 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -64,15 +64,15 @@
(define-public check
(package
(name "check")
- (version "0.10.0")
+ (version "0.12.0")
(source
(origin
(method url-fetch)
- (uri (string-append "https://github.com/libcheck/check/files/71408/"
- "/check-" version ".tar.gz"))
+ (uri (string-append "https://github.com/libcheck/check/releases/download/"
+ version "/check-" version ".tar.gz"))
(sha256
(base32
- "0lhhywf5nxl3dd0hdakra3aasl590756c9kmvyifb3vgm9k0gxgm"))))
+ "0d22h8xshmbpl9hba9ch3xj8vb9ybm5akpsbbh7yj07fic4h2hj6"))))
(build-system gnu-build-system)
(home-page "https://libcheck.github.io/check/")
(synopsis "Unit test framework for C")
@@ -85,20 +85,6 @@ faults or other signals. The output from unit tests can be used within
source code editors and IDEs.")
(license license:lgpl2.1+)))
-;; XXX: Some packages require this newer version. Incorporate this
-;; into the main 'check' package during the next rebuild cycle.
-(define-public check-0.11.0
- (package
- (inherit check)
- (version "0.11.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/libcheck/check/releases"
- "/download/" version "/check-" version ".tar.gz"))
- (sha256
- (base32
- "05jn1pgb7hqb937xky2147nnq3r4qy5wwr79rddpax3bms5a9xr4"))))))
-
(define-public cunit
(package
(name "cunit")
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 1e18cd31c9..73cd4c7a10 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -1097,7 +1097,7 @@ connectivity of the X server running on a particular @code{DISPLAY}.")
("xcb-util-wm" ,xcb-util-wm)))
(native-inputs
`(("bison" ,bison)
- ("check" ,check-0.11.0)
+ ("check" ,check)
("flex" ,flex)
("pkg-config" ,pkg-config)))
(arguments