aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ruby.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index e282a6f24e..07f1a01b87 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4981,3 +4981,36 @@ Markdown.")
in standard Ruby syntax.")
(home-page "https://github.com/ruby/rake")
(license license:expat)))
+
+(define-public ruby-yajl-ruby
+ (package
+ (name "ruby-yajl-ruby")
+ (version "1.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "yajl-ruby" version))
+ (sha256
+ (base32
+ "1rn4kc9fha990yd252wglh6rcyh35cavm1vpyfj8krlcwph09g30"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:test-target "spec"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'patch-test-to-update-load-path
+ (lambda _
+ (substitute* "spec/parsing/large_number_spec.rb"
+ (("require \"yajl\"")
+ "$LOAD_PATH << 'lib'; require 'yajl'"))
+ #t)))))
+ (native-inputs
+ `(("ruby-rake-compiler" ,ruby-rake-compiler)
+ ("ruby-rspe" ,ruby-rspec)))
+ (synopsis
+ "Ruby C bindings to the excellent Yajl JSON stream-based parser library.")
+ (description
+ "Ruby C bindings to the excellent Yajl JSON stream-based parser library.")
+ (home-page
+ "http://github.com/brianmario/yajl-ruby")
+ (license license:expat)))