aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ruby.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index c1e571c6a9..1e9ff31582 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5995,3 +5995,35 @@ using a strict syntax definition and supporting several common extensions.
")
(home-page "http://kramdown.gettalong.org")
(license license:expat)))
+
+(define-public ruby-prawn
+ (package
+ (name "ruby-prawn")
+ (version "2.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "prawn" version))
+ (sha256
+ (base32
+ "0z9q3l8l73pvx6rrqz40xz9xd5izziprjnimb572hcah6dh30cnw"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; Further dependencies such as pdf-inspector need to be
+ ; packaged.
+ (propagated-inputs
+ `(("ruby-pdf-core" ,ruby-pdf-core)
+ ("ruby-ttfunk" ,ruby-ttfunk)))
+ (synopsis
+ " Prawn is a fast, tiny, and nimble PDF generator for Ruby
+")
+ (description
+ " Prawn is a fast, tiny, and nimble PDF generator for Ruby
+")
+ (home-page
+ "http://prawn.majesticseacreature.com")
+ ;; Prawn is released under a slightly modified form of the License of Ruby,
+ ;; allowing you to choose between Matz's terms, the GPLv2, or GPLv3.
+ (license (list license:gpl2 license:gpl3
+ (license:non-copyleft "file://LICENSE"
+ "See LICENSE in the distribution")))))