aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/disk.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index b9240a392a..11454d85f8 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -171,3 +171,35 @@ transport), SCSI and ATAPI tape drives, and SCSI enclosures. This utility can
also send commands associated with starting and stopping the media, loading
and unloading removable media and some other housekeeping functions.")
(license bsd-3)))
+
+(define-public idle3-tools
+ (package
+ (name "idle3-tools")
+ (version "0.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/idle3-tools/idle3-tools-"
+ version ".tgz"))
+ (sha256
+ (base32
+ "00ia7xq9yldxyl9gz0mr4xa568nav14p0fnv82f2rbbkg060cy4p"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;no test suite
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))
+ #:make-flags (list "CC=gcc"
+ (string-append "manprefix=")
+ (string-append "DESTDIR="
+ (assoc-ref %outputs "out")))))
+ (home-page "http://idle3-tools.sourceforge.net")
+ (synopsis "Change or disable Western Digital hard drives' Idle3 timer")
+ (description
+ "Idle3-tools provides a utility to get, set, or disable the Idle3 timer
+present in many Western Digital hard drives. This timer is part of the
+\"IntelliPark\" feature that stops the disk when not in use. Unfortunately,
+the default timer setting is not well suited to Linux or other *nix systems,
+and can dramatically shorten the lifespan of the drive if left unchecked.")
+ (license gpl3+)))