aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/curl.scm11
-rw-r--r--gnu/packages/ssh.scm18
2 files changed, 1 insertions, 28 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 46e0fa0f16..222910b655 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -54,16 +54,7 @@
(inputs `(("gnutls" ,gnutls)
("gss" ,gss)
("libidn" ,libidn)
-
- ;; XXX libssh2-1.4 is a temporary package for use only by curl,
- ;; to allow most users of libssh2 to get the security update for
- ;; CVE-2016-7087 while postponing the large number of rebuilds
- ;; entailed by updating curl. Soon, curl should be updated to
- ;; use the latest libssh2 and libssh2-1.4 should be removed.
-
- ;; XXX libssh2-1.4 is vulnerable to CVE-2016-0787.
- ("libssh2" ,libssh2-1.4)
-
+ ("libssh2" ,libssh2)
("openldap" ,openldap)
("zlib" ,zlib)))
(native-inputs
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 081c7cbe32..1b4a4b4777 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -112,24 +112,6 @@ a server that supports the SSH-2 protocol.")
(license license:bsd-3)
(home-page "http://www.libssh2.org/")))
-;;; XXX This is a temporary package for use only by curl, to allow most users
-;;; of libssh2 to get the security update sooner while postponing the large
-;;; number of rebuilds entailed by updating curl.
-;;;
-;;; XXX This package is vulnerable to CVE-2016-7087.
-;;;
-;;; https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-0787
-(define-public libssh2-1.4
- (package (inherit libssh2)
- (version "1.4.3")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://www.libssh2.org/download/libssh2-"
- version ".tar.gz"))
- (sha256
- (base32
- "0vdr478dbhbdgnniqmirawjb7mrcxckn4slhhrijxnzrkmgziipa"))))))
-
(define-public openssh
(package
(name "openssh")