aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ruby.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index ff00a898a4..d03999b913 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5730,3 +5730,34 @@ percentage, bars of various formats, elapsed time and estimated time remaining.
"WebMock allows stubbing HTTP requests and setting expectations on HTTP requests.")
(home-page "http://github.com/bblimke/webmock")
(license license:expat)))
+
+(define-public ruby-crack
+ (package
+ (name "ruby-crack")
+ (version "0.4.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "crack" version))
+ (sha256
+ (base32
+ "0abb0fvgw00akyik1zxnq7yv391va148151qxdghnzngv66bl62k"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (zero? (length
+ (filter (lambda (file)
+ (display file)(display "\n")
+ (not (zero? (system* "ruby" file))))
+ (find-files "spec" ".*rb$")))))))))
+ (propagated-inputs
+ `(("ruby-safe-yaml" ,ruby-safe-yaml)))
+ (synopsis
+ "Really simple JSON and XML parsing, ripped from Merb and Rails.")
+ (description
+ "Really simple JSON and XML parsing, ripped from Merb and Rails.")
+ (home-page "http://github.com/jnunemaker/crack")
+ (license license:expat)))