aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 930dc933d8..1842907f92 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6437,3 +6437,28 @@ to support fast builds of The Ruby Racer")
to support fast builds of The Ruby Racer")
(home-page "http://github.com/cowboyd/libv8")
(license license:expat)))
+
+;; haml 4 cannot currently be packaged because tilt is not yet packaged.
+(define-public ruby-haml
+ (package
+ (name "ruby-haml")
+ (version "4.0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "haml" version))
+ (sha256
+ (base32
+ "0mrzjgkygvfii66bbylj2j93na8i89998yi01fin3whwqbvx0m1p"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; circular dependency with tilt
+; (propagated-inputs `(("ruby-tilt" ,ruby-tilt)))
+ (synopsis "Haml (HTML Abstraction Markup Language) library.")
+ (description
+ "Haml (HTML Abstraction Markup Language) is a layer on top of HTML or XML
+that is designed to express the structure of documents using indentation rather
+than closing tags. It was originally envisioned as a plugin for Ruby on Rails,
+but it can function as a stand-alone templating engine.")
+ (home-page "http://haml.info/")
+ (license license:expat)))