aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index fb5d2fd16a..a22be5c794 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10960,7 +10960,10 @@ failures.")
(modify-phases %standard-phases
(delete 'check)
(add-after 'install 'check
- (lambda _ ; It's easier to run tests after install.
+ (lambda* (#:key outputs inputs #:allow-other-keys)
+ ;; It's easier to run tests after install.
+ ;; Make installed package available for running the tests
+ (add-installed-pythonpath inputs outputs)
(zero? (system* "py.test" "-vv")))))))
(native-inputs
`(("python-coverage" ,python-coverage)