aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/emacs-xyz.scm54
1 files changed, 24 insertions, 30 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 667a7f5d3c..15fef73d3d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15066,37 +15066,31 @@ files. It focuses on highlighting the document to improve readability.")
(license license:gpl2+)))
(define-public emacs-rust-mode
- (let ((commit
- ;; Last release is old (2016), use more recent commit to get bug
- ;; fixes.
- "64b4a2450e4d4c47f6307851c9b2598cd2254d68")
- (revision "0"))
- (package
- (name "emacs-rust-mode")
- (version (git-version "0.3.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/rust-lang/rust-mode")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0pbz36lljgb7bdgx3h3g0pq1nss1kvn8mhk1l3mknsmynd6w4nd8"))))
- (build-system emacs-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (invoke "sh" "run_rust_emacs_tests.sh"))))))
- (home-page "https://github.com/rust-lang/rust-mode")
- (synopsis "Major Emacs mode for editing Rust source code")
- (description "This package provides a major Emacs mode for editing Rust
+ (package
+ (name "emacs-rust-mode")
+ (version "0.4.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rust-lang/rust-mode")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0bcrklyicxh032rrp585rl5mxd26nb61dp6r5bl935rlcmxzsczh"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "sh" "run_rust_emacs_tests.sh"))))))
+ (home-page "https://github.com/rust-lang/rust-mode")
+ (synopsis "Major Emacs mode for editing Rust source code")
+ (description "This package provides a major Emacs mode for editing Rust
source code.")
- (license (list license:expat
- license:asl2.0)))))
+ (license (list license:expat
+ license:asl2.0))))
(define-public emacs-ztree
(let ((commit "c54425a094353ec40a8179f9eab3596f76c6cf94"))