aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5e26fe724f..8d34ea2e1e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4055,13 +4055,17 @@ logging and tracing of the execution.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-before 'check 'disable-tests
+ (add-before 'check 'adjust-tests
(lambda _
+ ;; Drop use of testtools.helpers.safe_hasattr which has
+ ;; been removed in favor of hasattr.
+ (substitute* "test/test_metadata.py"
+ (("testtools\\.helpers\\.safe_hasattr")
+ "hasattr"))
;; FIXME: Determine why test fails
(substitute* "test/test_daemon.py"
(("test_detaches_process_context")
- "skip_test_detaches_process_context"))
- #t)))))
+ "skip_test_detaches_process_context")))))))
(propagated-inputs
(list python-lockfile))
(native-inputs