aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/kde-frameworks.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 012731572b..5482400f02 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016-2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
@@ -3476,6 +3476,13 @@ script engines.")
("qtdeclarative" ,qtdeclarative)))
(arguments
`(#:tests? #f ;; seem to require network; don't find QTQuick components
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'dont-use-qt515-logic
+ (lambda _
+ (substitute* "src/externalprocess/purposeprocess_main.cpp"
+ ((" 15") " 16"))
+ #t)))
#:configure-flags '("-DBUILD_TESTING=OFF"))) ; not run anyway
(home-page "https://community.kde.org/Frameworks")
(synopsis "Offers available actions for a specific purpose")