aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/crypto.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index db39166d45..dd49c12e5b 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -633,6 +633,16 @@ data on your platform, so the seed itself will be as random as possible.
(lambda _
;; By default, only the static library is built.
(invoke "make" "shared")))
+ (add-after 'install 'install-shared-library-links
+ ;; By default, only .so and .so.x.y.z are installed.
+ ;; Create all the ‘intermediates’ expected by dependent packages.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (lib (string-append out "/lib")))
+ (with-directory-excursion lib
+ (symlink "libcryptopp.so.8.0.0" "libcryptopp.so.8.0")
+ (symlink "libcryptopp.so.8.0.0" "libcryptopp.so.8")
+ #t))))
(add-after 'install 'install-pkg-config
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))