aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6ef76dba99..fec7ab22cb 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8991,3 +8991,28 @@ pcredential store, Pass, Secret Service, KDE Wallet, Encrypted File.")
(home-page "https://github.com/mtibben/androiddnsfix")
(license license:expat))))
+(define-public go-github-com-aws-aws-sdk-go
+ (package
+ (name "go-github-com-aws-aws-sdk-go")
+ (version "1.36.18")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aws/aws-sdk-go")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "169mkkw1cff1px6326krwvfpfj07sb4y5rbn003gi4bk176h6ry9"))))
+ (build-system go-build-system)
+ (native-inputs
+ (list go-github-com-jmespath-go-jmespath))
+ (arguments
+ '(#:import-path "github.com/aws/aws-sdk-go"
+ #:phases %standard-phases))
+ (synopsis "The official AWS SDK for the Go programming language")
+ (description
+ "The official AWS SDK for the Go programming language.")
+ (home-page "https://github.com/aws/aws-sdk-go")
+ (license license:asl2.0)))
+