aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/video.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 3a043fb34f..8aedc1c2f5 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1326,6 +1326,14 @@ SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
(arguments
'(#:phases
(modify-phases %standard-phases
+ (add-after
+ 'unpack 'patch-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((ytdl (assoc-ref inputs "youtube-dl")))
+ (substitute* "player/lua/ytdl_hook.lua"
+ (("\"youtube-dl\",")
+ (string-append "\"" ytdl "/bin/youtube-dl\",")))
+ #t)))
(add-before
'configure 'setup-waf
(lambda* (#:key inputs #:allow-other-keys)