aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/haskell.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 9af661ae3f..fcbd231d7b 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2383,6 +2383,29 @@ or timeout period. This package provides alternative functions which use the
unbounded @code{Integer} type.")
(license bsd-3)))
+(define-public ghc-nats
+ (package
+ (name "ghc-nats")
+ (version "1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/nats/nats-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0r6s8l4s0yq3x2crrkv0b8zac13magfasr9v8hnq6rn1icsfhic0"))))
+ (build-system haskell-build-system)
+ (arguments `(#:haddock? #f))
+ (inputs
+ `(("ghc-hashable" ,ghc-hashable)))
+ (home-page "https://hackage.haskell.org/package/nats")
+ (synopsis "Natural numbers")
+ (description "This library provides the natural numbers for Haskell.")
+ (license bsd-3)))
+
(define-public ghc-doctest
(package
(name "ghc-doctest")