aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2cd6f55f4d..79eac0ec7f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3701,6 +3701,7 @@ text styles of documentation.")
(sha256
(base32
"05mps9r966r3dpqw6zrs1nlwjdf5y4960hl9m7abwb3qyfnarwyc"))))
+ (replacement python-pygments/fixed)
(build-system python-build-system)
(arguments
;; FIXME: Tests require sphinx, which depends on this.
@@ -3712,6 +3713,17 @@ text styles of documentation.")
(license license:bsd-2)
(properties `((python2-variant . ,(delay python2-pygments))))))
+(define python-pygments/fixed
+ (package/inherit python-pygments
+ (version "2.7.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Pygments" version))
+ (sha256
+ (base32
+ "0dy35ry5qa8dpklk4fkj9kfpw2qb4mh5ha9866kw30wf96dx0jfz"))))))
+
;; Pygments 2.6 and later does not support Python 2.
(define-public python2-pygments
(let ((base (package-with-python2 (strip-python2-variant python-pygments))))