aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/wine.scm31
1 files changed, 17 insertions, 14 deletions
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index a3022e045b..ca5c969fff 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -323,7 +323,7 @@ integrate Windows applications into your desktop.")
(define-public wine-staging-patchset-data
(package
(name "wine-staging-patchset-data")
- (version "4.18")
+ (version "5.0")
(source
(origin
(method git-fetch)
@@ -332,7 +332,7 @@ integrate Windows applications into your desktop.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "03z0haf47mpm2aj9cji3wma4jy6j12wz10kkbgmbgrkkrc5lcqc2"))))
+ (base32 "054m2glvav29qnlgr3p36kahyv3kbxzba82djzqpc7cmsrin0d3f"))))
(build-system trivial-build-system)
(native-inputs
`(("bash" ,bash)
@@ -369,18 +369,21 @@ integrate Windows applications into your desktop.")
(inherit wine)
(name "wine-staging")
(version (package-version wine-staging-patchset-data))
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://dl.winehq.org/wine/source/"
- (version-major version) ".x"
- "/wine-" version ".tar.xz"))
- (file-name (string-append name "-" version ".tar.xz"))
- (sha256
- (base32
- "0chf6vdy41kg75liibkb862442zwi8dbjzf6l5arcy2z4580a2yi"))))
- (inputs `(("autoconf" ,autoconf) ; for autoreconf
- ("faudio" ,faudio)
+ (source
+ (origin
+ (method url-fetch)
+ (uri (let ((dir (string-append
+ (version-major version)
+ (if (string-suffix? ".0" (version-major+minor version))
+ ".0"
+ ".x"))))
+ (string-append
+ "https://dl.winehq.org/wine/source/" dir
+ "/wine-" version ".tar.xz")))
+ (file-name (string-append name "-" version ".tar.xz"))
+ (sha256
+ (base32 "1d0kcy338radq07hrnzcpc9lc9j2fvzjh37q673002x8d6x5058q"))))
+ (inputs `(("autoconf" ,autoconf) ; for autoreconf
("ffmpeg" ,ffmpeg)
("gtk+" ,gtk+)
("libva" ,libva)